Electron stopped working?

Cool, if you can use that to read out a 1MB binary off of the STM32F205 that would be, helpful. You can PM a link to it or email it to me brett @ particle and the io part :wink: We should also be able to get you back up and running with that, by flashing a new combined image to the device, and fixing the keys. Please mention your JTAG tool to support if you haven’t already.

Also it would be good to know what system firmware was running on the device when it failed to boot.

1 Like

Thanks for working with us on this, @GavinS!

1 Like

I think I’m having the same issue. I had my Electron on an Asset GPS board.

I was using a brand new 3.7V pouch battery along with supplying 12V to the board with a DURA12-1.3F AGM. I started running the 1-gps-features.ino demo script last night at about 8:00PM (which I altered to send data every minute to test). It was running great :sunglasses: so I left it running all night … I received data until today at 12:25PM.

Circa 12:45PM: the red light was on (external battery) but the activity light was not (that usually throbs light blue). I unplugged both batteries. I checked the batteries a few hours later … the Lipo was completely dead and the AGM was down to about 5V. (I certainly should have had an LVD on there.)

Now when I power up the board either way I’m just getting the blue dim D7 light. Guessing this is a similar issue to @GavinS

In the meantime … (I’m guessing I’ll have ordered another new Electron before I figure out the problem with this one) …

  • What is the expected behavior when the battery runs low?

  • Any recommendations on code where I’d check the voltage with the Fuel library and then manually shutdown if either the Lipo or the external AGM dip below certain levels? (I’ll have external voltage sensors on B4 / B5).

Thanks !!!

Yeah I seem to be seeing this with another Electron!

Was working fine for a few days, Now its stuck in this dim blue light mode. Buttons wont do anything, seems bricked again… I was using the provided Electron battery this time as well.

Not sure the trigger/event that got me here…

1 Like

So if an Electron has no lights except the Dim Blue D7 there is no way to get it out of this state?

Anything I can do with it ?

Hi @GavinS

It sounds like your Electron is in the “no firmware” state. It can be recovered with a JTAG programmer for sure, but you will need help.

I would contact Particle support and ask for help with this.

A possible shot, if you have no JTAG programmer or Particle Programmer Shield, might be this already mentioned methode

As long you have one good Particle device, this might be worth a shot.

1 Like

Yeah, I tried that Norwegian Blue (SWD) thing. The lights come on, but it just sits there. I left it “fixing” it for days.

I’d love to know how to use the JTAG debugger on this. I may need to make a new cable. I have a Tin Can Tools Flyswatter 2, but it doesn’t have open pins, just a JTAG cable. The cable is to small to stick jumper wires in, so I definitely need a new cable.

I haven’t tested this yet … but I was measuring the voltage of the external battery with an external voltage sensor on B4.

If I detect the external voltage has gone below … say … 11.0V … and I call PMIC.disableCharging() … I’m hoping that’s enough to keep me from replicating the “DIM Blue D7” situation. (I’m assuming at this point disableCharging handles whatever disableBuck and disableBATFET also do).

Is there also a method buried in PMIC that will give me a current reading on VIN? Then I could add a second built-in safety mechanism to never have charging enabled if VIN is below … 8V or so (enough to allow demoing with a 9V battery I guess).

Hey all, just wanted to let you know we are pooling our thoughts and testing on this issue here:

Hello, any updates on this? I have experienced the same issue with my electron, dim blue D7 light. I am trying to go through the SWD Norwegian Blue but can’t seem to get the programmer app to work in the serial terminal after flashing to photon. I am using a working photon to remedy my electron. After flashing ,I have connected to Particle CLI and enter: particle serial monitor. No messages appear. Any help on this issue and how to save my electron would be much appreciated! Thanks

1 Like

My apologies, it works when I open the terminal with Coolterm. However, I get the same fault as @jasonp. I’m open to suggestions. Thanks

1 Like

Hi all. Sadly we have now experienced this as well :frowning: Even worse, it happened while we were demoing our product overseas :frowning: However, the reason I really wanted to post is that we may be able to add an important bit of information: Our battery was charged. It was probably around 60-70% charged. However, our product has this button on its exterior that we use to hard power off the unit:

That button breaks the ground connection to the battery (battery becomes open circuit when OFF). We were demonstrating this, ie using our on/off button. We turned our product on and everything worked fine, we turned it back off and then when we went to turn the unit back on again we got the blue light of death. So in our case I am pretty sure it wasn’t from a battery drain, but from the on/off cycle. Now, there is one complication to this: before re-powering after our last successful power-on our external case was opened. This should not have made any difference at all and is unlikely to have contributed to the failure, but it is a change that happened right before the failure so I have to report it.

I have also killed an Electron by allowing the battery to go completely flat and having no RGB LED activity.

I connected up the programmer device (Photon) to the Target device (Electron). However, when I tried the Norwegian Blue program, I got no activity in my serial monitor. I only got the steady blue light on the Photon, and no change on the Electron. Therefore, I can’t even run the Bootloader.

I tried the serial monitor in conjunction with the Blink an LED example, and it appears to be working fine.

EDIT: I used CoolTerm instead and was able to display the serial messages. I got the SWD Fault error:

Do you have a dead device and wish to continue? [y,N]:y
SWD Fault error
Please double check the wiring, then try again.

I have the same issue with my electron, but my battery was not even below 3.7v. It was basically brand new and had only run my code less than 200 times. I don’t remember exactly what I was doing, but there was some combination of plugging/unplugging the battery and usb and it stopped working. Only the D7 led is on and the red battery led will function. I tried following the bootloader repair procedure, but I got the same “Please double check the wiring, then try again” error. I’m pretty sure my wiring is correct.

I’m having the same issue with 2 of my 14 electrons here on fieldwork. I have a small solar panel connected to them and found that when the battery is not attached, but the panels catch a little light, they brick up. This suggests to me that it is not a voltage, but amperage problem: my panels only deliver something like 150 mA max, but always at 6V (I checked).

to safe my fieldwork campaign, I really need a workaround on the “SWD Fault error”. Does anyone have anything? I can not get a JTAG here in Myanmar (not faster than more electrons anyway… and certainly not before the end of the campaign)

any help appreciated.

The solar panel will only supply 6v under no load. The voltage will collapse down to 0v once you put more than a 150mA load on it, so there is still an under voltage issue going on with your setup.

Why do you not have a battery connected? Were you just testing without one real quick?

Do you have code that prevents the battery from discharging below 20% to prevent the Electron from possibly bricking due to low input voltage?

I’m testing the Electron + 5v 3w solar panel and so far after a month the unit has been outside in cloudy winter weather and always goes to sleep when the SOC is below 20% and comes back online after the solar panel charges the battery back up above 20% SOC when the sun is out.

What is your Campaign exactly?

You’re right that the voltage will drop under load.

In our experiments, the solar panels are permanently connected to Vin. When we start our experiments, it sometimes happens that the solar panel gets a bit of (Myanmar, tropical) light before we get the battery in. That is what causes the brownouts.

Our experiments is about tracking floaters that float down the Irrawaddy river to estimate velocity, but more importantly dispersion. See https://www.instagram.com/researchrolf/ for some impressions.

2 Likes

Thank you for the reports everyone. I think many of you are also familiar with the Bug Bounty post over here because I’ve seen some of you post over there as well. If not, please go take a look and see if there is anything you might be able to contribute. We’re currently still digging into this issue and looking for the culprit. Please keep the reports coming with details, they are very helpful!

@RolfHut which solar panel are you using, and which system firmware version?