Electron E0 UART5 / Serial 5

Hello ;

We are designing a commercial weather station with the E0 module and currently having trouble with UART5 / Serial 5. Every time I compile and flash code that uses Serial 5 the module runs through the loop once and eventually locks up the device. All other serial ports work fine except this one. After pulling my hair out I made this simple program to confirm that I am not crazy :

#include “Serial4/Serial4.h”
#include “Serial5/Serial5.h”

void setup() {

void loop() {
Serial.println(“Usb Serial”);
Serial5.println(“Serial 5”);

After I flash this the device locks up and needs to be put into safe mode in order to reprogram it, if I comment out the Serial5.println line the problem goes away. Currently I am running OS v0.7.0 and I have tried with 5.4 and 6.4…

Does anybody have any advice on this one?


I’m not sure what would cause that behavior. I used your code and ran it on the E series evaluation board running system firmware 0.7.0 and it worked as expected. It stayed breathing cyan.

Just to be sure I connected a logic analyzer to C1 and I got the expected serial data once per second.