Downgrade error "file was too big"

Hi there,

we are currently facing a problem when trying to downgrade a P1 from 1.5.0 to 1.4.4 (or lower) via CLI OTA. It results in an error “Update failed - File was too big!”. It is the original release file from github with size of 253KB. Flashing our firmware bins worked fine.

We did this downgrade several times before on other P1s and never saw this problem.

Does anyone have any idea how to solve this issue?


You can try to downgrade to 1.2.1 and then back up to 1.4.4.

1 Like

Thank you for that hint @ScruffR, but it is the same issue with 1.2.1.
Do you think it is caused by the CLI or by the P1? I just reset CLI installation - without success.
I tried another PC to see if there is any difference, but I get the same error.

Have you got any chance to flash via USB?

unfortunately not - the P1 is already build into a product ready to ship :roll_eyes:

Update to 1.5.1 via CLI was not possible (“file was too big”), so I compiled a test firmware for 1.5.1 that did the update. Now I am on 1.5.1 but I still get the same error at CLI when flashing 1.4.4/1.2.1

I’ll have to defer to @rickkas7 for that then.

Got it! It seems to be a short time slot for flashing without error when restarting and the cloud connection has just been established. It was hard to get the slot two times for the two parts, but finally it worked.
The system is now at 1.4.4 - all right!