Dfu-util failed to list Redboard [Solved]


#1

Hello Guys,

I managed to update keys on Photon Redboard under DFU mode. Redboard can be put in DFU mode successfully (blink yellow). However, I got “Error - No DFU device found” when executed ‘particle keys server’ or ‘particle keys doctor’ command. I also tried ‘dfu-util -l’ and got ‘Cannot open DFU device 2b04:d008’.

dfu-util version is 0.8. And I’ve done the same thing on Photons for many time without any problem. Any clue or suggestion?

Thanks,
Baoshi


#2

What OS?
If Windows, have you got the drivers installed?


#3

Windows 10 with Particle_Windows_Serial_Drivers. DFU-util works well on Photon, but not on Redboard. I just noticed in windows Device Manager when I plug in a Photon and put it in DFU mode, it can be recognized and marked as “Photon DFU mode”. However, when it comes to the Redboard, there will be recognized as “Photon DFU mode” too but with an exclamation mark. I reinstalled the driver and picked P1 instead of Photon. Still no luck. Then I tried to update the drive to particle_drivers_6.1.0.51. It prompted no particle driver is required on Windows 10.


#4

p.s. Once the Redboard is plugged in, Device Manager can find it and name it as P1 Control Interface.


#5

ParticleCLISetup solves my problem. P1 DFU mode finally shows up. Everything is OK. Thanks ScruffR. You are right. It was a driver problem.