Dfu-util binaries while dfu-util.gnumonks.org is down

I emailed Tormod Volden of the dfu-util project to ask how users should get binaries since the normal download site is currently down. He replied with a tarball of binaries and an MD5 hash for me to post.

Download link:

MD5 hash: 9a7b0594881c9ba8480bdc9956b5b01a



For a quick install, this topic proved to be really useful!

1 Like

Could you tell me how can i use both link and MD5 hash

Hey @Omar, you can simply download the file using the link. The MD5 hash is used in case you want to check for the file integrity.

Other than that, it should work just fine :wink:

1 Like

What about on a Mac? Looks like there are just windows files in that bundle? Or did I just miss it?

hmm… does homebrew work for you? I can’t figure out but they probably pull from the gitorious repo and install it

homebrew is trying to use the defunct gnumonks site unfortunately. I don’t know much about what goes on behind the scenes with homebrew.

Anyone have experience building it from source for Mac?

I copied it out from my user/local/bin directory if you trust: https://dl.dropboxusercontent.com/u/36134145/dfu-util :smiley:

1 Like

Hey All!

I was chatting with the maintainers of dfu-util, and in the meantime while they’re working on getting the site back up, they’ve placed a mirror here:


Hopefully it’ll get indexed in the next few days, but that means it’ll still be broken for stuff like homebrew / macports / etc.


I found a workaround that worked for me on Mac.

Since Homebrew is looking for v0.7, I copied that release (dfu-util-07.tar.gz) from the mirror you posted (http://dfu-util.sourceforge.net/releases/) into the Homebrew cache directory (/Library/Caches/Homebrew)

Then when I did a brew install dfu-util it found it in the caches folder and proceeded with installation.

Thanks @Dave and @kennethlimcp!


I am also running a Mac (recently upgraded to Yosemite) and Resseguie’s technique worked for me except that I had to do thls as well: “brew link --overwrite libusb”. Somehow, I had a previous version of /usr/local/lib/libusb-1.0.0.dylib and the symbolic link. I didn’t invent this command, it was suggested in the output of “brew install dfu-util”.

I’m on a OSX 10.9 and I got some issues installing and running dfu-util. I installed Homebrew a few month ago, so I had to update the repo with “brew update” command before to be able to install dfu-util (this way the old download link is replaced by the new one).
Hope this advice helps someone.

1 Like

I see that there’s and install for windows 32, what if I have windows 64, can I still use it?

I use it on 64 without issue. All you need is the 4 or 5 files and add the directory where you save it to your PATH

Installing via brew install dfu-util now works. It’s now getting its data from https://homebrew.bintray.com/bottles/dfu-util-0.8.yosemite.bottle.tar.gz

That’s the beauty of homebrew. If the recipe doesn’t work, you can change it.

1 Like