Debugging with eclipse

Not sure if this is the right place to post this. Well I’ve been trying for a few days to get the debugger to work properly and I’m having no luck. I have tried to use strictly command line and I am currently trying to setup eclipse to work either the programmer shield on windows. I can can connect to the device and I can read sources but break points don’t seem to. In eclipse everything is setup and seems to be linked correctly but the build fails and I have been unable to figure out why. Below is a screenshot of eclipse error and the Command line GDB errors . Any help on how to correct this error would be greatly appreciated.

Reinstalled and configured Cygwin and now I have different errors.

At this point I have no clue what I’m doing. just fumbling around in the dark. The error message makes no sense to me. I think something is pointed to the wrong place so the build process can’t find the correct file.

What version of the gcc-arm toolchain do you have installed? You can use:

arm-none-eabi-g++ --version

What branch of the firmware repository did you clone?

Are you able to build from the Cygwin command prompt (not Eclipse):

cd firmware/main
make clean all PLATFORM=photon MODULAR=n DEBUG_BUILD=y
1 Like

@rickkas7 Thank you for the response!

version returns 5.4.1

arm-none-eabi-g++.exe (GNU Tools for ARM Embedded Processors) 5.4.1 20160919 (release) [ARM/embedded-5-branch revision 240496]

I am using branch 0.7.0 and would like to use 0.8.0 in the future.

And build from main failed.


That’s one of your problems. Only version 5.3.1 can be used to successfully build system firmware.

I am not sure anyone has tried to get the local compile makefiles working under Cygwin. They work on Windows (with a reasonable shell) and on Linux and Mac without any emulation layer.

@rickkas7 I did read that at some point somewhere in all the posts. Must have forgotten that detail. I’ll give it a try.

@bko Ok i’ll keep that in mind I have other shells and minnGW as well.

Thanks, I’ll let you know how it goes!

@rickkas7 Ok I changed versions and ran a local build which seems to have run correctly. The version on the photon is now 0.8.0. I can connect using openocd but from there i’m a bit confuse as there are no locals. I did break setup which looks like it successful places a break point in application.cpp at line 40.

But if I continue the photon resets for some reason and I cant do anything with it at that point unless I put it back in DFU mode. Do these errors mean anything to you guys?