Dead Electron Red BAT LED won't blink

After a brief happy life on a breadboard, my Electron stopped breathing. The RGB led went off and would not come on.
I removed all power USB cable, LiPo, and power at VIN from the Particle relay shield 5V and GND.
In doing so I noticed that the LiPo red LED did NOT blink when battery was removed. Red LED stayed on with no LiPo plugged in.
I removed the Electron from the breadboard and plugged in the LiPo. Both the ublox and ARM got very hot. Couldn’t touch the ARM (perhaps that heat transferred to ublox). No RGB LED.
Used another LiPo from a Photon Battery shield. No improvement. Tried USB w/o LiPo. Red battery LED on solid no RGB.
I was very careful to observe 3.3V limit on Analog input pins. I used the relay shield as a power source because my battery could get up to 14V while charging and the relay shield will take 20V. I didn’t want to exceed the 12V spec for VIN.
No noticeable heat when USB is only power source.
At time of death, the LiPo read 4.0V. My sketch was routine no mucking the battery other than monitoring fuel gauge.
Model G350. Firmware via WEB IDE 0.4.8 flashing in safe mode over USB.
Now what?

It sounds like your Electron is dead. It shouldn’t get hot with USB powering it.

It will be valuable to try to figure out why it died… you said you were powering it from the Relay Shield. The new black relay shield or older white one? Where you controlling anything with the relay shield? What other connections might be hooked up. How does your battery that can go up to 14V get charged, is it part of your automobile? BTW, automobile sounds so funny to me, but I hope it’s the clearest word for a car/truck/vehicle.

Do you have a volt meter? If so could you measure VIN and 3V3 with respect to GND when you apply power via USB? How about when you only apply power from the relay shield (no USB cable)?

thanks for help… the third paragraph from bottom says no heat problem when power from USB.
yes I’m using a 12v car battery hence 14V when charger will be applied.
the new relay shield - black
Am I asking for trouble by moving the old sim card to my new U260 Electron?
My guess is bad battery controller if it controls the red LED.
GND 3.3v pins - with just USB connected 0.5V (tried two ports and two electron cables)
GND VIN pins - 4.8 V
GND 3.3v pins - 0.5 when powered from black relay shield with no other power source
A1 A2 A3 were reading voltages all from voltage dividers verified to keep voltages well under 3V. (I used 5 identical resistors to divide 12V in anticipation of 14V charger someday)
D0 -D3 were used to control relay shield, status LED and enable an XL-MaxSonar-WR (used with Photon for 6 months w/o problems)

It sounds like your STM32F205RGY6 may be shorted… or any of the other buffers that are connected to 3V3. Did you have any signal conditioning on your power input to the relay shield? Automotive systems can easily generate +50 VDC transients that can damage low voltage electronics so typically you want to filter these transients with LC filters and then also provide TVS diodes to clamp the input voltage to something above the max battery voltage and something below the max limit of the device… in this case the Relay shield.

I’d be curious to know if the Relay Shield still works, and regulates to 5V on VIN. Was that your 4.8V measurement? It wasn’t clean to me if that was VIN with USB power or VIN with Relay shield power. It would also be interesting to see what the output of the Relay shield power supply looks like on an oscilloscope when hooked up to a car’s power supply… I’ll have to add that to my list of fun things to do :wink:

Here’s a nice app note from ST (tons of these out there) on what hazards are present on automotive power systems: http://www.st.com/web/en/resource/technical/document/application_note/CD00181783.pdf

Hmm… this could easily have been the source of death. Did you have 3.3V zener diodes in parallel with the analog inputs?

I’d say you got really lucky for 6 months.

I’m just using an automotive 12V battery standalone. This system will go out an orchard. When it works I’ll add a solar charger. I need hefty power because the relay will activate a 12V valve to control water.
I’m up and running again with a new Electron. Well sort of, I’m trying to get my IFTTT DOs working with new device name. The SIM switch went well. The Dashboard billing was smart enough to anticipate a SIM being moved from a dead Electron. The setup was smart enough to realize a SIM could be already activated.

Sounds like you have the relays on the shield controlling these valves. Do you have any clamping diodes on your valve coils? If not, you can generate a very high inductive kickback into the 12V system (potentially hundreds of volts).

Here’s a rundown of how the inductance will generate a high voltage: https://en.wikipedia.org/wiki/Flyback_diode

Your valve is the inductor and series resistor. The switch in that wikipedia circuit is your relay.

I couldn’t have asked for a better image from Google :smile:

Hopefully this reaches you before your second Electron goes to Electronics Heaven :innocent:

Thanks. all testing to date is w/o the valve connected, this sudden death caused me to think about the flyback diode on the valve to protect my relay shield. The Relay shield should isolate the Electron
I certainly hope, the relay shield designers were smart enough to include protection for the relays going on and off.
I’m well aware of the need as they are on the A/C clutches on autos.

The relays are controlled much like the picture above, with NPN transistors. They are not opto-isolated, but do have flyback diodes in parallel with the coils. The relay contacts are all isolated with routed PCB channels, for minimum creepage and clearance distances required for high voltage power supplies. I had another person recently have an issue with the relay shield, so I wrote an app that toggled all of the relays and I watched the power rails with a scope… they looked clean. I’ll have to revisit that test with a higher input voltage… I had tried 9VDC.

It should do when used as per specs, but if you are sharing the same 12V battery to power the shield and drive your valves, the induced voltage spike from the valve coil might feed back into the shield supply, exceeding its specs and protective capabilities for the Electron and consequently frying it.

To be clear, I’m not making any claim of a relay shield defect. I answered a comment about damage to my Electron resulting from reverse voltage surge from a solenoid by stating the damage would be to the relay shield not the Electron.

It sounds like you didn’t hook anything up to the relay screw terminal contacts though, right? If you had… and had done so without flyback diodes on the solenoids, that could have damaged the relay shield and/or the electron due to a common un-isolated power supply.

thanks you are right - never hooked up soleniod. I will definitely add the diode to valve solenoid when I get there and test for spikes standalone with my oscilloscope.

thanks. to be truthful I didn’t think that through. Perhaps, because I hadn’t yet connected the solenoid. I didn’t want to carry a big battery to my desk. I’m using a 12V screw driver battery for development and the solenoid would use it up really fast. By the way, I’m really estatic with Electron performance. It runs for days without hiccups. the IFTTT DO works great. I have a function that publishes an event and then IFTTT sends me an email with all my data. all with acceptable delays. my flashes go without failing. the serial output to terminal is problem free. I’m happy with my DO to enter safemode so I don’t have to struggle with tiny mode button to flash new firmware. the black and decker 12V battery pac will power the Electron for days.

1 Like