Cloud Flashing or Local Flash not uploading my program

Hey,

I’ve been working with a Particle Electron and for the past few months, everything has been flashing and compiling fine through the cloud (Using VS Code Workbench). However, today when I tried to flash a slightly edited version of my code (only changed the condition of an if statement), I think it ends up overwriting it with the default program that comes with the Electron. I have GPIO pin C0 connected to a transistor that enables a circuit to be powered when set HIGH (which is default is during setup) but I get no output from it. This is why I think the program I am trying to flash keeps getting overwritten. I can upload the blinking LED example from the Particle Web IDE, and tried flashing my program to the Electron through the Web IDE, but it still gets overwritten.

I attempted to flash local but I ended up getting an error. It sets the device to DFU mode but it says this error:

This still occurs even after I freshly reinstalled the CLI and compiler toolchain. Does this problem occur since VS code and the project are stored on different drives?

Any help would be appreciated. Thank you all for your time.

At first glance I would guess this a path issue. It looks like the parenthesis in Research(D) is causing an error. Have you tried creating and building a project in another location?

2 Likes

You can also switch on verbose build output

image

2 Likes

Thank you for the suggestions. I will try them out once I am able to get back to the Electron. I’ve worked with software that doesn’t like having spaces in the directories so it would make sense if the parenthesis is causing issues here. If that doesn’t work I’ll enable verbose compiler logs and see what messages I get from that.