Cloud data request has started timing out

I’ve been collecting data from a Core device into a google spreadsheet for a couple years. Recently the data collection has stopped and when I look at the log from the spreadsheet it says the UrlFetchApp.fetch() call times out. So I tried it from the command line with curl to eliminate google issues and this gives me the same response, as shown below. “data” is the variable that gets published containing the data gathered by the device.

{“error”:“Timed out.”}

I’ve verified that the device id and token are correct and that if I change either I get appropriate error responses from curl, either permission denied on a bad token or unrecognized device on a bad device id. I poked around the web and forums to see if something had changed that would require me to modify the invocation, but didn’t see anything except the same kind of call I’m making, though those posts are a bit long in the tooth in some cases. Any idea why I’m timing out? Has something changed that I missed that requires me to change the call?

Update: I used angle brackets in the curl line and they disappeared so I updated the line to indicate that I really do have the device id and token in the call.

Update the next day: OK, I just checked my spreadsheet and now it is returning data, for a while anyway. The curl works as well, of course. I don’t think the Cloud was really down as long as I was getting timeouts, so I still don’t have any idea of what was going on. Maybe someone has a suggestion? BTW: During the time that I was getting the timeouts, I was getting updated data on the dashboard, so the device was communicating and I could see it there. ???

Update a couple days later: Now it’s timing out again, though I can see from the dashboard that it is still sending data to the cloud. Any thoughts?

I’m having the identical problem today. Changing device code or access token produces appropriate messages but commands that worked previously are now getting timed out. I’m stumped. Anybody???

Oh good grief. Found my problem. all my old code had “” but “” works just fine.
Quoting Emily Litella, never mind.