Cloud Connection issue on first config

Hi all, I’m new to particle and have just got my photon.BTW, I locate in China. unfortunately, when trying to configure WIFI to photon , I got an issue So is the particle cloud server using some service from Google? As Google service is totally unavailable in china.

Try to reset your Photon and see if it can connect.
I’ve had similar cases, where the app reported an error, but the WiFi credentials got set propperly.
So your device might get onto the WiFi.
If it’s not claimed to your account tho’, you’d need to do that manually (or retry with the app).

I was there and pinging 8.8.8.8 works fine. My photon worked fine in China as well. :smiley:

You might have to use the CLI or a serial terminal as alternatives to set it up.

@juncaofish,

I spend a great deal of time in Qingdao, and suffer from issues like you have with Particle, and also no access to Google (or gMail :frowning: )behind the Great Firewall. Try Bing, works as a good search engine and provides plenty of returns for Particle/Spark.

You may want to try to set up a private VPN connection to US or Canada to configure your new Photon. I believe once you have that part done, it will connect easily to the Particle cloud servers. :slight_smile:

@BulldogLowell i never had to do that and my photon worked well there :smile:

1 Like

Well, it depends on your city and if you stay in a ‘western’ hotel. In HK, Shanghai, Beijing or Shenzhen I may be able to use Google while I am at hotels or in certain offices. Some of those hotels have VPN to foreign servers.

At my factory in Shandong Province and in most of the many places I visit in China, Google is blocked by Great Firewall, even if you can ping the server but a search is never allowed…

I could not set up a Photon in Qingdao, I redirected my internet through the VPN back to my office in USA, and that worked. After that, if I attached it to any Wifi network connected to the internet, it would work well, while I admit at times with considerable latency.

My point is that I don’t think it can be generalized that “it worked for me in China, so it should work for you” regarding access to any foreign server. Sometimes, the Firewall will block by default first… sometimes it gets blocked after it gets traffic.

You’re right. I managed to set it up at office today. Our company has set up net connection with abroad server. But I have just tried to configure photon with my home wifi and never got luck. Anyway, upon the error above, I reset photon and found the credentials got saved inside. I log out from the Particle app , log in again and found my photon there in the device list :smile: Now I could burn the firmware from the particle build website~ Thanks you guys. Next I want to give a try with the Blynk library on photon.

2 Likes