[Closed] Has the compiler changed?

Hi Particle,

We have experienced some trouble with getting our code to work after the 21. dec.

Code that we before where 110% sure worked almost suddenly would not run on the Electron or Photon. We have tried with flashing with firmware that we have created before the 21. dec. and it works as expected. Our problem now is that we cannot compile new code without errors (blinking red or cyan). We have tried almost anything changing firmware version.

Compiling the electron and flashing it with simple loop setup makes it blink red:

void setup() {


void loop() {


Any idea what have changed since the 21. dec?

After adding SYSTEM_THREAD(enabled); the code runs but it have problems connecting to the cloud.

What are you using to compile? Build, DEV or CLI?
What firmware version?
How many red flashes do you get?

Have you upgraded the Electron to 0.4.8 already?
Double check what version you are targeting with Web IDE.

It should be captials SYSTEM_THREAD(ENABLED).

Closed. See: https://community.particle.io/t/cloud-compiling-makes-invalid-firmware-if-compiled-on-52-2-65-116/18563/2