CLI unusable: invalid character '\x00'


I’ve been using particle CLI succesfully to flash my electron for a few weeks.
Today, out of nowhere, every request to the CLI gives me:
“ERROR: invalid character ‘\x00’ looking for beginning of value”


What did I do wrong? I’m using windows 10, perhaps an update when rebooting changed
a requirement or a dependence for the CLI?

I tried to reinstall CLI but that changes nothing, as “particle setup” gives the same response.

I’m getting crazy and don’t know what to do (except from flashing OTA)

If anyone knows what’s happening that would be great!

Thanks a lot

My guess is that your configuration is corrupted. In your user directory (C:\Users\xxx) should be a hidden .particle directory. Rename that to be .particle-old or just delete it. Then do a:

particle login

Thank you for your fast answer!
Unfortunately that does not resolve the problem :-/

Any other idea?

Finally fixed it.

For future reference:

  • C:\Users\username.particle contains only credentials (username, acces_token) and last_version_check. Delete folder in case of login problem
  • C:\Users\username\AppData\Local\particle was the right place in my case. Reinstall did not work. Uninstall.exe then supress the whole folder, then run ParticleCLISetup.exe worked like a clean install