Can't function L9110S with Argon

Hello,

I have particle argon, L9110S, motor. I am trying to control the motor using L9110S, but it doesn’t work. Below is my test code.

I tested the same setup and code with arduino, it worked.

const int a = D3;
const int b = D2;

void setup() {                
  // initialize the digital pin as an output.
  pinMode(a, OUTPUT);
  pinMode(b, OUTPUT);    
}

void loop() {
  digitalWrite(a, HIGH);  
  delay(10000);              
  digitalWrite(a, LOW);    
   delay(10000);       
 digitalWrite(b, HIGH);   
  delay(10000);       
  digitalWrite(b, LOW);    
  delay(10000);
}

I appreciate if you have any suggestions.

Thanks!

@andyd, a few more details are generally required so we can help:

  • Which DeviceOS version
  • Web link to L9110S board or breakout you are using
  • Web link to motor or description of motor specs you are using
  • How are the Argon, L9110S and motor powered
  • Circuit diagram (ideal) or description

Typically, if something works on an Arduino, it is because it is a 5v system, not 3.3v like the Argon, or that you are powering the L9110S from the 3.3v output of the Argon, which cannot supply enough current. Understanding your setup is key and thus the questions above.

1 Like

@peekay123, Thank you for your willingness to help.

DeviceOS version: 2.3.0
L9110S board link: https://www.amazon.com/HiLetgo-H-bridge-Stepper-Controller-Arduino/dp/B00M0F243E/ref=sr_1_1_sspa?crid=YNYTY5BHWYMT&keywords=l9110s&qid=1645897917&sprefix=l9110s%2Caps%2C80&sr=8-1-spons&psc=1&spLa=ZW5jcnlwdGVkUXVhbGlmaWVyPUExRURJUjJEMlZQUk9BJmVuY3J5cHRlZElkPUEwMjI5MzQwMTNNWUYxTlRLWFc2NSZlbmNyeXB0ZWRBZElkPUEwMjE2ODkxM0Q2UlBDV1VUSzI1SyZ3aWRnZXROYW1lPXNwX2F0ZiZhY3Rpb249Y2xpY2tSZWRpcmVjdCZkb05vdExvZ0NsaWNrPXRydWU=

In fact, it is DC latching solenoid valve.
DC latching solenoid Iink: https://www.amazon.com/Hunter-458200-DC-Latching-Solenoids/dp/B002P4WKUM/ref=sr_1_2?gclid=CjwKCAiAvOeQBhBkEiwAxutUVKt1ZCnWaUtUmyD5LB55XbimOVF2nFVhyX2v-gDxICVg3f-FH3zlGxoCyQwQAvD_BwE&hvadid=190534135102&hvdev=c&hvlocphy=1019499&hvnetw=g&hvqmt=e&hvrand=15360383497897397631&hvtargid=kwd-320624777514&hydadcr=28667_9845951&

Argon is just powered by USB now, and L9110S is powered by 9V battery.

Wire diagram:
Argon (D2) – L9110S (A-1A)
Argon (D3) – L9110S (A-1B)
9V Battery (Positive) – L9110S (VCC)
9V Battery (Negative) – L9110S (GND)
DC latching solenoid – L9110S (Motor A)

You need common GND (Argon GND <-> L9110S GND).
Without it the D2/D3 signals are “floating” with respect to the GND level of your battery.

1 Like

@ScruffR Thank you!

It worked. Learning new things everyday.