Can't connect through serial


#1

I am trying to connect an electron device.

I got the device to connect to the cloud and was able to login to my account after prompted for a username/password. I tried to use the Build IDE to simply flash a light but I am getting a message from the command prompt “serial: No devices available via serial”. I went through all of the steps to install the drivers and I tried all of my serial ports but none of them seem to work.

I also tried putting the device in DFU mode and doing the dfu-util -l command and I got the following…

I’m stumped. Any ideas of why I can’t get serial connection?
Thank you


#2

@adelira, when you say “the build IDE” do you mean the one on the web or do you mean Particle DEV? The web-based Build IDE doesn’t flash via serial, only OTA. Can you please clarify?


#3

The web-based build IDE. I was following a tutorial on github
enter link description herehttps://github.com/InitialState/particle-electron-gps-streamer/wiki/Part-2.-Using-the-Particle-IDE

Here is the gist of the part where I am getting stuck.

I tried the particle flash --serial firmware.bin command as well as the particle identify command both returned “serial No devices available via serial”. Maybe I’m just doing something wrong?

Thank you for the response.


#4

What OS are you on?
If Windows, have you got all drivers installed? Try the tool here
Have you got the most recent CLI version?
Check your USB cable or swap it anyway.
You could always try particle flash --usb firmware.bin for DFU flashing.


#5

I am on Windows 10.
I used the installation tool for CLI/drivers and this is what I got…

It gave me this in the command prompt for all 3 of my usb ports… I don’t have any other USB cables handy right now to try. I will try the particle flash --usb firmware.bin command as soon as I can.


#6

This is what particle flash --usb firmware.bin did for me. At least it found the device but how do I access the firmware?


#7

You need to be in the same folder as the firmware.bin file in order to run:
particle flash --usb firmware.bin


#8

How do I know where my firmware.bin folder is and how do I change it?
Thank you


#9

You executed that command from C:\Users\Alan but when you downloaded the firmware.bin you either got asked for a destination folder or it went into C:\Users\Alan\Downloads.
You could also go back to your browser, download the file again and then select show in folder (or similar depending on your browser).
But this should be basic Windows knowledge :wink:

Just as the use of cd Downloads from your above starting location would be.
Or you navigate to the folder in Windows Explorer, hold the Shift key and right click into the right Explorer pane and select Open Command Window here


#10

Strange… it never asked for any destination folder and no download ever popped up. I clicked the save folder and it just says “Firmware was saved successfully”. What type of file should it be? because there is nothing in my downloads or users folders.


#11

What browser?
Usually every browser has a menu item to show recent downloads with a context menu option to open Explorer in the parent folder.
And firmware.bin will be a … guess … .bin file (bin = BINARY), but I guess you have that darn “hide extensions of known file types” checked in the View menu/ribbon - uncheck that (or check “show extensions” if it’s called that way)

If you are using IE or Edge, you should also get a “save to …” button (or little arrow for extra options next to the button)


#12


#13

Thank you rikkas! Going to see if I can get it to work now.


#14

Yep I was able to flash through DFU thanks everybody.