Can no longer build Firmware in Eclipse[SOLVED]

I was setting up EGit in eclipse today and must have messed something up. I get build errors now. They are:

make: *** …/…/core-common-lib/build: No such file or directory. Stop.


make: ***[check_external_deps]Error 2

Any ideas? I think I have everything setup correctly.

Please check you have the core-common-lib and core-communications-lib repositories in the same folder as the core-firmware repo.

1 Like

Thank you @mdma mdma,

They are in the same folder. I believe I have that issue resolved since it has started building again.

I did also have run configurations setup to use dfu-util to flash firmware to the module. However now I get this error:
dfu-util: Could not open file core-firmware.bin for reading: No such file or directory
It seems the binary file is either not being generated or being placed in the wrong directory. Where are these settings set in Eclipse?

Thank you,
Travis Elliott

Hey @mdma,

Perhaps I spoke too soon. I am still getting the same error. Here is a screen shot of my Eclipse workspace. You can see that all required repositories are in the workspace. Is there some way I have to link them in Eclipse?

I’m sorry, I don’t use eclipse so I can’t really help with the eclipse setup.

However, I would suggest getting the build working form the command line first, following the instructions in the in the core-firmware repo.

@satishng does use Eclipse, so he may be able to offer some advice once you’ve got it working on the command line.


Thank you very much for the help @mdma. I did finally resolve my problem. I had inadvertently moved the core-common-lib folder at some point and that was the main cause of the problem. Once I got all three back in the same root directory everything is building and flashing through dfu-util in eclipse now. I have no idea how that folder got moved.