Calling function using the CLI not working

Hi
I am new at particle and Photon.
I got connected through Tinker with Android phone and I was able to play with digital and analog pins.
I installed Windows CLI .
I typed the command particle list.
My device appear as connected with its name and is on line.
But if want to switch on/off some pin with the function call like
particle call my_device_name digitalwrite D7 , High the answer is 2 , which is correct
but the LED doesn’t turn on.
What could be the reason for that ?
Thank you for any help

The cal shouldn’t have spaces in it, and it should be in capitals:

particle call my_device_name digitalwrite D7,HIGH

Give that a shot?

(The topic had absolutely nothing to do with the title, so I’ve changed it accordingly)

1 Like

Thank you Moor7 for your answer.
It was a typo when I wrote this post.
You are high, should be in capitals but when I tried high was well written and nothing happened.
What other reason can be the cause of it because my device is recognized with its ID and is online?
Thank you for let me know about the post’s title.

Could you show us an output of the CLI when you issue “particle list”?

It still looks as though there’s a space between D7 ,HIGH, which shouldn’t be there.

Try copy&pasting particle call Test_1 digitalwrite D7,HIGH, and see if that works?

1 Like

Hi Moors7

I worked out the issue.
Thank you very much for your help

1 Like