Boron stuck in DFU by particle update

I am desolate, a few days ago I performed the setups of my new Boron 2g/3g with internal sim card and everything worked fine, today I wanted to update my boron with the particle update command unfortunately from the console I received an error like below and it ist flashing yellow fast:

C:\Users\valentino>particle update
> Your device is ready for a system update.
> This process should take about 30 seconds. Here it goes!
! An error occurred while attempting to update the system firmware of your device:
Error: VError: Error writing firmware: Invalid DFU suffix signature
A valid DFU suffix will be required in a future dfu-util release!!!
Error during special command "ERASE_PAGE" get_status
> Please visit our community forums for help with this error:
Cannot read property 'code' of undefined

I state that I have carried out the suggestions given to me by ScruffR in my other place with a similar error but with negative results.

particle flash --usb tinker -v
particle update -v
particle flash --usb tinker -v

Can someone give me an idea how to get out of the DFU (blinking yellow) situation and recover the device.
Thanks Valentinio

Hi Tino,

can you post the logs of your particle flash ... commands too?

Also, when you add -v to particle update you should get a more verbose output about the potential reason for the error.

If nothing helps, you could try to remove CLI and reinstall it afresh and then try again.

You may want to create a support ticket as the error “Error during special command “ERASE_PAGE” get_status” may indicate a hardware failure (the operation failed when erasing the flash memory).

thanks @rickkas7 and @ScruffR for your answers this evening I will open a ticket to the technical support as recommended.
Greetings from Switzerland

Hello @ScruffR and @rickkas7
after opening a ticket I received a reply msg where they asked to execute the command particle update -v again.
This solved the problem I am attaching below what was written in response to technical support.

Boron is now alive. I used the particle update -v command and this was successful.
After the message ‘Your device should now restart automatically.’ it stayed in listening mode flashing blue I ran the particle usb setup-done command and went into safe mode to get out of this situation I ran the particle flash --usb tinker command. Now everything is in order but I would like to understand where I went wrong at the beginning.

Thanks also to you for your availability in the community.

This topic was automatically closed 182 days after the last reply. New replies are no longer allowed.