Boron not tracking data usage


#1

I’ve been able to setup and run my Boron device. Everything works as I’d like with exception of tracking data usage. I can do everything I expect with it, however, one of the things I’m working on is optimizing the amount of data sent. However, it doesn’t seem to be tracking.

  1. Is this expected?
  2. Is there a way to track sim data usage for a device? (aside from counting characters in a message :smile: )

Thanks!
Nathan


#2

Boron cellular data usage is not currently supported, but should be in a future version. I don’t have a specific release for when it will be added back in.

The only other way I can think of doing it for now is to use the Electron Cloud Manipulator, but that’s a pretty difficult solution to the problem. If you can wait, that will be much easier.


#3

@will should the New Boron LTE not tracking data usage be added to the known issues that need fixed quickly on the new devices?

It’s a very important feature.

@rickkas7 Is the default 5MB cellular data limit currently enforced considering the lack of data usage numbers on the Boron LTE? Has this been confirmed to be working?


#4

I’m sorry, I misread the original post. There are actually two separate issues:

  • I was referring to the Cellular.getDataUsage command, which isn’t implemented on the Boron yet.
  • There’s a separate issue for data usage in the console for Boron devices may not be accurate.

I’ll investigate the implications of the second, but I’m pretty sure you won’t get billed unexpectedly.


#5

There was a bug in our data usage importer script that was preventing us from importing usage data from our carrier partner. We just released a fix that should allow us to once again import usage data for LTE SIMs. Please let us know if you are still not seeing usage data for your SIMs.

There is currently a delay in how quickly our carrier partner is able to get us the usage data (it can take several days), so the usage data you see will be old. We are currently working with our carrier partner to improve the speed in which data usage is reported.


#6

Awesome! Thank you.

Thanks for everyone’s help!
Nathan


#7

Will I be able to use Cellular.getCellularUsage on the device to see how much data is has used??

I didn’t know about it before but that’ll be really helpful when available.

Thanks!
Nathan


#8

Hey! I’m still not seeing data usage for my LTE sim devices.
I know last month, I did cross the 3mb limit. I’m for certain I did this month as well; I left my GPS unit running (and publishing every 2 seconds) overnight.

Thank you for your help!
Nathan

** Update: One of my LTE devices is showing data usage now! So maybe the others will catch up soon?!