Boron LTE will not connect to Particle cloud using Internal Sim if an External Sim is installed

I am currently testing a few Boron LTE devices with hybrid 0.8.0-rc.27 OS.
Using the Internal Particle Sim, they quickly and very reliably connect to Particle cloud on power up and have stayed connected for days.

I haven’t been able to use 3rd party sim to connect using the prescribed commands.
Also, if External Sim is installed…even if INTERNAL_SIM is selected it will not connect to Particle Cloud. Only if EXTERNAL SIM is removed?

Any thoughts!

I think I was able to reproduce that. I haven’t had a chance to debug it to see what is happening, but for now I’d definitely remove the 3rd-party SIM card if you are not using it (as of 0.8.0-rc.27).

As it turns out, this is a hardware limitation of the Boron. You either need to insert a 3rd-party SIM card and fully configure and use it, or remove it in order to use the internal SIM card. You can’t switch back and forth in software only.

Interesting, would this ever remove the requirement to also have to set this in firmware?

This was exactly what I asked behind the scenes :wink:

There are extra considerations to be made.
Since Boron 2G/3G does in fact allow to select, the SIM select command won’t be redundant for Borons entirely, but having two diffenrent command sets for Borons is no option either.
Also if SIM selection was automatized it may cause confusion when the ext SIM detection should happen to fail and falling back to a non-activated internal SIM wouldn’t be helpful either.
SIM detection/switching would also incure extra boot-up delays as switching would require a reset of the cellular module.

Ah I see! I suppose as long as the “getActiveSim” (or whatever that command was) returns the source of truth for what the modem is using, I think the current behavior seems reasonable (once documented) since it allows the user to at least have an indicator, such as create some kind of a warning flag, pipe an error to serial for debug, etc.

Greetings @rickkas7

Thanks for the explanation.
I will make sure that External Sim is removed when using Internal Sim.