Boron commercial power monitor

Hello,

I am trying to duplicate the Commercial Power Monitor as described in this post

My boron is running 2.0.0 and when commercial power is restored, rather than returning to commercial power, the boron constantly switches back and forth between battery and USB power as shown in this Ubisoft’s graph.

The charging led flashes amber and the only way to break the cycle is to disconnect both battery and usb and then connect usb first then reconnect th3 battery.

Do I need to downgrade to version 1.4.4 as in the previous post?

Thank you in advance.

I tried with a different lipo battery today. Same issue.

Hi, and welcome to the community!
curious here, how do you know it switches from bat to USB power?
thanks

Thank you for your support.

I modified the code in the example to send the powerSource value from the DiagnosticsHelperRK.h to Ubidots instead of a “sanitized” 0 and 1.

If I boot the Boron on battery power, it reports a value of 5 (POWER_SOURCE_BATTERY). When I connect a USB cable to the Boron, it reports a 1 (POWER_SOURCE_VIN) and then starts bouncing back an forth between 1 and 5 every 3 to four seconds. Here is a sample where I coded the Boron to send the powersource to Ubidots.

If I unplug the USB power cable, the Boron reports a 5 and then stops sending reports as specified in the code.

BTW, I am using an Apple 5.2V DC 2.4Amp power supply connected to the USB port on the Boron. I have tried several different power supplies and all act the same.

thanks for the clarification.

@rickkas7 would you know by any chance what can be happening here?
thank you