Boron can't connect to external API

boron
Tags: #<Tag:0x00007f1ca1950d48>

#1

Hey Here…,
Am working to the project of accessing external server using Boron external SIM, could someone here can help how i can connect my boron V 0.9.0 to external API using boron cellular with external SIM …?

here is the simple code i was tested just to check if i can connect to my server and get my IP but it’s didn’t works

#include "Particle.h"
#include "dct.h"

SYSTEM_MODE(SEMI_AUTOMATIC);

void setup() {
   Serial.begin(9600);
   Cellular.setActiveSim(EXTERNAL_SIM);
   Cellular.clearCredentials();
   Cellular.setCredentials("internet");
   Cellular.on();
   Cellular.connect();
}
void loop() {
 SimType simType = Cellular.getActiveSim();
 Serial.printlnf("simType=%d", simType);
 Serial.println("Connected successfully");
 Serial.println(Cellular.localIP());
 delay(10000);
}

@ScruffR, @nrobinson2000 and @rickkas7


#2

One thing I’d do earlier in your setup() would be calling Cellular.on().
If you want to program the cellular module, I’d make sure it’s actually powered on :wink:


#3

@ScruffR have you ever tried to use cellular before? …cause i tried to call Cellular.on () but no change


#4

Yes, I have.
But I’ve not experimented with 3rd party SIMs on a Boron (yet), but I’d also not need to in order to understand that not having the module powered up would render most additional steps in-vain.


#5

Great, could you please help me to fix this …?


#6

What provider is your 3rd party SIM and where did you get the APN info for that provider from?

Some rules of thumb I tend to apply (necessary or not - I don’t care :wink: , better safe than sorry)
I’d only call Cellular.clearCredentials() once and not again till you actually want to revert back to the Particle SIM.
You may also want to power cycle the modem after you set the new credentials.

If I find time, I’ll try to set one of my Borons to 3rd party and see how I can make it work.


#7

am using Airtel rwanda sim

42%20PM


#8

Is it stuck at blinking green (can’t connect to tower) or does it get to blinking cyan (light blue)?

And just to be sure:

  • You’ve activated the SIM with Airtel.
  • The SIM does not have a PIN code. Even 0000 will not work, it must have no SIM PIN at all.
  • This is a Boron 2G/3G, not a Boron LTE, correct? The Boron LTE will almost certainly not work there.

#9

@rickkas7

  1. it’s blinking cyan
  2. SIM is activated
  3. SIM doesn’t have any PIN
  4. it’s Boron 2G/3G

Note: but am using USB flash code cause am familial with VS code


#10

Blinking cyan may indicate bad particle device keys. Can you put the device into DFU mode (blinking yellow) and then use the particle cli to try fixing the keys? You may need to get the device ID using particle serial identify if you don’t already have it.

docs