Azure IoT Hub set up error: Cannot read property 'value' of undefined

Why am I getting a “Cannot read property ‘value’ of undefined” when trying to set up Azure IoT Hub?

I am literally at the first step of the setting up the Azure IoT hub intergration and cannot get past this step. I just set up my Azure account today using the free promotion offer.

This image highlights the ‘Pricing and scale tier’ option. If I select other pricing options the error doesn’t go away.

This image hightlights the area under ‘Subscription’ there are no other options in the drop down…

I’m tempted to think this is a Microsoft problem, and not a Particle one. You might want to try clearing your browser’s cache and/or restart your browser and/or use a different browser.

Hej @Moors7, I have the same issue and I tried your advice but It still does not work for me. Did It work for you? Have you tried anything else?

I personally haven’t tried it, but it looks as though there’s an issue on Microsoft’s end. Not sure if there’s much that we can do about that.

I was able to get a response from Azure, it was an error in their system:

5/29 IoT Hub - Emerging issue under investigation -