Asset Tracker GPS Power

Has anyone experienced any issues powering the GPS hardware which ships with the Particle Asset Tracker kit? I can’t get mine to power up at all. I assume I will get some sort of power indicator such as a flashing “fix” led much like the Adafruit ultimate GPS, I have the Adafruit GPS working just fine.
I have attempted to power this unit by both the screw terminal power connector and the header.

Hey Jim,

I’m sorry you haven’t seen any replies to your post. Can you post a picture of your setup? I’d like to make sure you have everything inserted correctly.


Hello how are you? I have the the asset tracker(AT). What I did to power it was to install the Electron in the female herders of the AT and just connect the Lipo battery to the Electron and it won’t power on.

What you need to do is to update the firmware on the Electron to the asset tracker library and then it will power on and search for GPS fix

Also I do recommend Connecting over USB and if you are a beginner it would be great if you comment on/like this post Better way to firmware update via USB :grinning:


Thank you for your reply, I had not tried that until you mentioned it but unfortunately it did not work for me.I’ll be posting some pics.


Have you tried this with

  1. asset tracker code running on the Electron
  2. a battery plugged into the Electron


(note, see what @mohit said below, it’s much more informative)

Hello Jim @JimtheGreat,

Power to the GPS modules is controlled by a MOSFET connected to D6 of the Electron when plugged in. Pulling the D6 pin low turns ON the GPS module. This is easily accomplished by using the AssetTracker library and the sample code. We also recommend plugging in the LiPo battery in the Electron and the CR1220 coin cell in the shield.

Make sure that the shield has a clear view of the sky and the horizon to get a quicker fix. After you have acquired a fix, the fix LED will go from blinking once a second to OFF state.

Hope this helps and let me know if things work out for you!


Many thanks! I’ll give this a try in the next few days.


Thank you! It is working perfectly. Though I am quite familiar with the Adafruit ultimate GPS which I was using on my Electron previously, I had no idea that i needed to turn this one on first.

Thanks again to you and @Jean-Pierre,


1 Like