Argon/Xenon not showing offline


#1

I have noticed that my Argon and Xenon are not showing up as offline in the My Devices list when they are powered off. There’s also no ‘offline’ event in the event logs as well.


#2

That is correct. For the purposes of the cloud, mesh and cellular devices don’t have online and offline state.

It’s possible that this feature could be added in the future, but for now it does not exist.

The reason is that for cellular devices, the online/offline state is very unreliable because the device to cloud ping only happens every 23 minutes, so there’s no way to tell if the device went offline any time in that period. Since it was so unhelpful, the online/offline state is not kept.

Mesh devices uses the same technology (UDP), so it suffers the same problem.


#3

Yes, I had read that the cellular devices use UDP and therefore won’t show that the device is offline. With the Xenon using UDP, that makes sense as well. But my Argon (WiFi) isn’t showing offline. My Photons show offline in the web console, but my Argon is not, it’s always showing online even when power is disconnected and power has been disconnected for 24 hours. :thinking:


#4

That’s because the Argon, Boron, and Xenon all use UDP. Also any device in an Ethernet FeatherWing.

Only the Photon, P1, and Core use TCP.


#5

I get that the status maybe unreliable, but shouldn’t you allow us the option to enable that feature, with warnings that online/offline only update every 23min (or whatever it is) and/or allow software control for that?
I.e. the Argon in gateway mode should use TCP and update online/offline as thats its sole purpose for being in gateway mode!
A bit disappointed :frowning:


#6

Making the device online indicator more accurate is scheduled for the second quarter of 2019. [Edited. Oops!]


#7

2018???