Argon, LiPo, wifi

I’m having a project of using the Argon to receive data from my electricity meter.
The meter has a Home Area Network connector, providing VCC, ground and data in/out.
I’ve set up the code to be able to receive data, no problem there.
However, I want to be able to power the Argon from the VCC and ground connection.
VCC is around 4.1V.
It can only supply 75mA, but using sleep modes and some caps, I think it should be possible to make it work for sending out short bursts of MQTT messages every 10 seconds or so.

I’m trying to power the Argon from the VCC pin, connecting it to the LiPo connector.
The board does “boot”, - however, it seems to crash and reboot when trying to connect to wifi.

I wondered if it was a problem with the 75mA limit, so I tried to connect a real lipo battery instead.
But here the same thing happened - when wifi tries to connect, the board reboots.
That’s weird, since - in my mind - it should be possible to run with wifi, when running off a battery… right??


I am not as familiar with the Argon as the Boron but, to answer your last question - yes, you can run the Argon off a LiPO battery and connect to WiFi.

For powering the device, you have three options:

  • VUSB - you can use this pin which is connected to the USB connector, it expects between 4.5V and 5V so your 4.1V may be a bit low.
  • 3.3V - you could use to power the device but would need more current
  • Li+ pin - your 4.1 volt input could work here.

I think the big problem is that you are not providing enough current as the Argon can consume over 250mA when connecting.

Take a look at the data sheet for the specs and, perhaps, share your code as it should work with a charged LiPO battery




Hey - thanks for your input, but unfortunately it doesn’t help

Like I mentioned, I did try to run the board off a battery - and it gave the same issue.
I even tried connecting a bench supply - set at 4.1V - to the Li+ pin - and the bench supply has plenty of amps to give, but same issue.

Is the Argon just rebooting - going from blinking green, off briefly, then possibly a white blink, before going back into blinking green?

Or is it going through a SOS panic (red blinks)?

Does the device boot if you power by the Micro USB connector?

I set the system mode to manual, since I wanted to be able to charge a capacitor when the system gets powered - so there was some extra juice ready for connecting wifi.

So the code starts by sleeping for a little while, to let the cap charge,
then connect to wifi, and then sleeping a bit more.

I set up the led to indicate, so I get blue when the system starts, then it turns off during sleep.
Purple while connecting to wifi - then back off while sleeping again.
finally orange, while connecting to particle, and then another round of sleeping.

This works fine, when using the micro USB connector - it goes through all the stages, and finally starts transmitting MQTT messages when entering loop().

However, when I power the Argon through a battery (18650) (using the Li+ pin) it goes through blue, turns off, purple for about a second (a delay I put in), but then goes white very shortly, and goes back to blue… and so on repeating.

I could understand if just using a cap would be difficult, but I think it should be possible to work with a battery…
The battery is fully charged and reads 4.17V on the dmm.