Argon and Xenon USB Serial working with PuTTY but not with other Terminals

Hi
Looked at other threads but none seem to cover my issue. Sorry if I have missed the solution elsewhere.
Argon and two Xenon networked and talking to each other with no problems but whilst USB serial works with PUTTY it does not work with other terminals whilst various Photons and Cores connect with no problems.

Example - Using Terminal v1.9b by Br@y - Sees and connects to Argon and Xenon BUT does NOT display any characters and the terminal freezes.

Installed (zadig) CDC - no change but now will not zadig back to original driver!

PuTTY - works though.

Devices show up as working USB ports in device manager.
Windows 10, Surface Pro 3 and Surface Go.
Device Firmware 0.8.0-rc.27

Are you using the correct baud rate, parity, stop bits, etc.? I’ve seen it in some terminals where if the Flow Control was set incorrectly (pretty much anything other than OFF), the terminal wouldn’t display anything because it won’t get the flow-control signal from the serial connection emulated over a USB.

Standard setting for USB RS232 emulation, 8,none,1 no handshaking. Simple test code on a Photon works perfectly but not on Argon/Xenon. I suppose what I am asking is - are there any differences between Argon/Xenon emulation and Photon?

Does particle serial monitor --follow work?
I had similar behaviour with some terminal programs that required me to send a byte from the terminal to the device in order to “activate” the return path.
The reason was - despite no flow control was set - the DTR/RTS flags were checked by the terminal program.

e.g. PuTTY has two settings for no flow control (DTR/RTS enabled or DTR/RTS disabled).
I’m running DTR/RTS enabled.

Thanks for your help.

  1. serial monitor works.
  2. The needing to send a byte to start coms has been with the Photon since an update a while back but always worked.
  3. Difference with Argon is the terminal emulator freezes after sending a byte - need to ‘close program’ to recover. Looks like overload of incoming Rx data but no way to well as it freezes.
  4. Tried all handshaking options.
  5. Tried a couple of other ‘terminals’ - same result.

That’s very strange. I have no issues with any of my mesh devices running rc.27 on Windows 10 Pro 64 bit Surface Pro 2018 or Lenovo Yoga 15

Could you share your code or try a less “agressive” firmware?
What other terminal programs did you use? I tried TeraTerm and Arduino Serial Monitor - both work.

BTW

I have managed to counteract that behaviour by making sure the control lines are set correctly.

1 Like

Hi
TeraTerm works fine, thanks for that, also tried Termite - no go, freezes.

//Just to test USB serial comms

void setup() {
pinMode(D2,OUTPUT);
Serial.begin(38400);
}

void loop() {
digitalWrite(D2,HIGH); //Flash LED
delay(50);
digitalWrite(D2,LOW);
delay(1000);
Serial.println(“Hello”);
}

Happy to leave it for now, will use TeraTerm for debugging and revisit “Terminal” another time.

Going to walk around the property to see how far the Xenon will communicate with the Argon.

Thanks for your assistance, have a great 2019.

1 Like

Hi
Set DDR RTS lines and now working which is great as ‘Terminal’ is an excellent tool.

Still begs the question though as why there is a difference between Mesh products and Photon?

Thanks Again

1 Like