Android app stuck on "connecting to photon" (SOLVED)

I’m totally newbie to the photon and this kind of device.
I just got my photon yesterday, and followed the connecting tutorial.
My photon is flashing blue, and when I try to connect it with my android phone, the app remains stuck to “connecting to photon”.
I tried the tip logging out and then in again as suggested in another post, but no change.
Any suggestion?

Have you tried a different USB power source and/or cable ?

Hi Mora
Thanks for considering my problem.
Yes I did try to connect my photon with another cable on my PC. The results remains the same.
To be fully complete:

  • I first had this problem during the first 2 hours I tried
  • Second day, with the same procedure, it suddenly became possible to go further, until the last connection step, where it failed : setup process could’nt claim your photon,and the LED was breathing cyan (probably the same problem described in this post Connection to Photon [SOLVED]).
  • Then today, I even can’t go further the first connection step, I remain stuck. Quiet strange because I think I went through the same procedure than the day before…

You have the whole story…

If you had your Photon already breathing cyan you can get the rest done without the app too.
You don’t have to go through all of the previous steps again.
Your device might be already claimed as well.
You can check this on the online IDE and if it isn’t even claim the device there.

I went on the online IDE and when I want to flash an app I have the message no device yet.
I’d like to add my device but it’s not clear where to find the device ID, informations on the photon box doesn’t work : couldn’t claim device message…

If you put your device into Listening Mode (blinking blue) by holding SETUP for about 3sec you can retrieve the device ID with a serial terminal sending i to the device and it will respond with the device ID.
Go to Web IDE, choose ADD NEW DEVICE and copy paste the ID into the respective box.

If you already have Particle CLI installed all this can be done there too.

OK, thanks for helping.
I finally solved the situation by using another android terminal, an Asus zenpad10 to successfully claim my photon.
Very strange that it remained unsuccessfull on my phone (samsung galaxy core). Ishould have tried this before…