After flashing argon device goes into Listening Mode

Hey everyone,
since I owned the device my device goes into listening mode after flashing any code.
The only way get get it out of the mode is use the mobile app click the gear icon click on wifi let it do its thing once it pulls up the ssid settings i can exit ouf of the app and im good to go.
How do i get the argon go directly into standard or connected mode after flash?

HI @donavon89 , which device are you using?

I suppose you have seen these guides? Device Blinking Dark Blue – Particle Support

https://docs.particle.io/tutorials/device-os/led/boron/

https://docs.particle.io/tutorials/device-os/led/argon/

The most likely case is that the setup done flag is not set. This is normally set by the mobile app, but if you set up the device by USB or cleared the credentials in the past, it may not be set.

The easiest way to set it is to use

particle usb setup-done

https://docs.particle.io/reference/developer-tools/cli/#particle-usb-setup-done