Workbench Local Flash occasionally requires hard reset?

I’m now using the Particle Workbench for local compile and flash. I’m attempting to flash to a Boron running 1.4. Not sure if it’s just me but I’d say 50% of the time when flashing over USB through CLI or the “flash” button in workbench, the device requires a hard reset via either the reset or mode PB. Once the flash is complete, the RGB light goes from flashing yellow to turning off. Acutually it has a very faint flicker. The other 50% of the time, it’ll boot right back up without a reset. Here is a quick video of what I’m seeing. Not sure if I should be concerned or not. I guess as long as it doesn’t do that with OTA updates its not a big deal. I’ve tested this on two different boron devices and both behave similarly. Thoughts? I can share/send a video if needed.

Hi @jgskarda!

Can you reupload that video (or better, post a link)? I’m curious to see this play out.

Does this issue occur if you compile and flash some known firmware to the device (like Tinker for example)? What about a flash via CLI of particle flash --usb tinker?

Hi Marek, Yeah, I sure can. What’s the best practice for sharing videos? Upload to Youtube and post a link here? Looks like these forums doesn’t allow uploading videos. Just let me know what you prefer.

I have not tried a known firmware (like Tinker) I’ll do that tonight. It’s happened with both the “compile button” where the device is automatically put into DFU mode and flashed once compiled as well as using the built in CLI within VS Code using Particle Flash --usb (name).bin. Since it’s a Boron I did not try cloud flash as i didn’t want to consume a bunch of cellular data. The video I have is using the CLI within VS Code to initiate the flash.


Here’s my plan of action:

a) yes, let’s see particle flash --usb tinker (in fact, hold off on the video until this step).
b) if you can reproduce the issue with Tinker, Youtube please! :slight_smile: (or Google Drive perhaps even better)

My guess is that the device is crashing upon startup, and that it’s not so much an issue of compilation/flashing and moreso one of the device being in some funky state due to application firmware. Might as well throw a particle update into the mix, as I’ve found this to be a miracle cure for “funky states” induced by flashing issues.

1 Like

@marekparticle, Here are my steps I did:

  1. Created new project in VS Code/Workbench
  2. Added the Tinker Library, copied the example .INO file in tinker to my main project.ino
  3. Compiled locally and copy/pasted the .BIN file created to the my project directory.
  4. Flashed using CLI (Particle Flash --usb Tinker.bin)
  5. First two times it work, 3rd time it did the flickering light thing until hard reboot. Here is a video:
  6. Ran the command (particle update). Once this was done it also did the flickering light until hard reset.
  7. Flash the same tinker .BIN (Particle Flash --usb Tinker.bin) atleast 10-15 times now with no issue.
  1. Flashed my full project .BIN with no issues.

So looks like running Particle Update fixed it. Just was odd that it also did the light flickering thing immediately/as it finished the particle update but I can’t make it happen again. I’ll monitor but I think i’m good to good.

Also just FYI, I believe this is the Boron I opened up out of the new box maybe 3-4 weeks ago. I originally flashed it OTA. So this involved multiple updates/cycles as it stepped it up to whatever it came as to 1.4. That was the only time I updated the root firmware. Overall, I think Partilce Update fixed it though so i’ll use that method in the future.


Thanks for the detailed report of the issue!


Thanks for the update and addressing this. I’ll keep my eye out for the next device OS release.

Just wanted to follow up that DeviceOS 1.4.2 is out and should resolve this issue.


Thanks for the update @avtolstoy and for the quick response to this issue. I’ll update my devices tonight. Have a good weekend.