[WORKAROUND]Photon Time Not Syncing

Using the SparkTimeExample from the SparkTime library I get “Not Sync” errors. The example returns a non-sense time:
“2036-02-07T00:33:34Z” and the seconds is always “50”

and when I add the snippet:

if (rtc.hasSynced()==true) {
  } else {
    Serial.print("Not synced");

the result is: “Not synced”.

Some other posts say I’m supposed to do a "deep update"

Thought I’d do sanity check before I go down that rabbit hole. I would have thought new Photon would have cleaned that up. I’m a little nervous doing a deep update on a brand new product.

Don’t worry about the deep update, that’s only applicable for the Core. For the photon, you could try updating to 0.4.6. If you’ve flashed anything over the web IDE, that should’ve already happened. If not, try flashing something. Alternatively, use the particle CLI, while in DFU, and issue particle update, to get you to 0.4.6

Doesn’t hurt and might solve your issue. If not, let us know, and we’ll see where we can help out.

Hi @davegutz

There is a problem on Photon right now with hostnames that have more than two “dots”:

Can you try changing “north-america.pool.ntp.org” to just “pool.ntp.org” and see if that helps?

1 Like

bko, that fixed it. Don’t know if that’s permanent or not but it’s a great workaround for now. Onward! Thank you.

How do we mark this post as SOLVED?

1 Like

You simply edit the title to add [SOLVED] :smile:

Thanks. I have 0.4.6.

1 Like

Thanks. I like [WORKAROUND] that you added better.