Webhook beta no longer working?

Is anybody else having issues with the webhook beta feature?

It seems like my webhook is no longer being fired. The last occurrence I see is from 2014-10-26 04:25:06.

I still see it in the CLI:

$ spark webhook list
Found 1 hooks registered

1.) Hook #xxx is watching for "logEvent"
    and posting to: https://xxx.com/events/
    created at 2014-09-05T20:44:23.698Z

@Dave is this just me?


Hmm, it looks like it’s still up and running for most people, I suspect maybe you left deviceID: "" in your json file, and it’s trying to match against an empty string?


Thanks for checking it out.

I’m not sure what JSON file you mean (also unsure of what deviceID you’re referencing).

Just a little more info, I am seeing the event via the subscribe CLI, but still no request to my webhook endpoint:

$ spark subscribe mine
Subscribing to all events from my personal stream (my cores only) 
Listening to: /v1/devices/events


I deleted the webook and added it again via the CLI. No other changes, but now it’s working. Solved?

Hmm, that’s strange, thanks for the heads up! We still need to add some monitoring and alerts to webhooks before they get released, I’ll keep an eye on it!


Hey @Dave I have noticed the webhook lasts a week then stops working, ive had to delete and re-add mine a few times now… when they work they are great… super fast

1 Like