Troubleshoot: Particle-CLI on windows [Q&A]


#81

Have you tried checking that?


#82

Umm how?

-Multiple Systems (one with a brand new Windows instal)
-Different Node Installers
-32Bit and 64bit

Still didn’t work. Also followed Kenneth’s guide to the letter except for them I tried to install Node 4.00 and it broke everything.

It also worked the previous everytime I installed node to the system path. Every single time… It even is an option to the installer that is selected and is adding it to the path.

Keep in mind that not everyone is a coder and understands how coding and object based coding children work in the OS level. Most people in my experience who post here seem to understand coding, but when someone like me posts we get so confused we just give up.


#83

It can’t find Git. If you try installing that, it might help.


#84

I did do that. The installer for github and the main installer. Also C++ desitro


#85

Is Git also in the path?


#86

It also worked the previous everytime I installed node to the system path. Every single time… It even is an option to the installer that is selected and is adding it to the path.

Yes


#87

I know that feeling.
Pre 1.13.0 versions of CLI didn’t need Git in order to install, but the newer versions do.
So “it previously worked” does not indicate that Git was part of your path, hence better double-check.


Can't install Particle CLI - git error
#88

Thanks, that was very useful. (genuine)

I have Github installed, (fresh), but still get the error. I also tried

npm install git

but no go. Any other ideas? Maybe what the Environmental variable should be? I found a similar topic on this, (not related to particle), but it’s EV didn’t work either.

Microsoft Windows [Version 6.1.7601]
Copyright © 2009 Microsoft Corporation. All rights reserved.

C:\Users\kreilly>npm install git
git@0.1.5 node_modules\git
└── mime@1.2.9

C:\Users\kreilly>


#89

I’m releasing a new version that will fix this issue by not using git anymore. It will be up very shortly.


#90

Very much appreciated man, always a pleasure.

I had a suggestion I made a new topic for that might be worth it. If I can figure out how, I could make it myself.


#91

Getting the error below when running any particle command.
Commands seem to work ok, haven’t tried serial monitor though.
OS: Windows 7 Enterprise
Node: 6.9.5 LTS

   λ particle
Error loading command C:\Users\collig\AppData\Roaming\npm\node_modules\particle-cli\commands\SerialCommand.js Error: %1 is not a valid Win32 application.
\\?\C:\Users\collig\AppData\Roaming\npm\node_modules\particle-cli\node_modules\serialport\build\Release\serialport.node

Welcome to the Particle Command line utility!
Version 1.19.2
https://github.com/spark/particle-cli

Usage: particle <command_name> <arguments>
Common Commands:

    setup, list, call, get, device, identify, flash, subscribe
    compile, monitor, login, logout, help, library

Less Common Commands:
    token, binary, cloud, config, function, keys, udp, update
    variable, webhook, wireless

For more information Run: particle help <command_name>

#92

How have you installed CLI?

If it wasn’t via the installer, try removing CLI and reinstall via this installer
https://binaries.particle.io/cli/installer/windows/ParticleCLISetup.exe


#93

I installed the manual way long ago.
Symantec does not play nice with the installer. See attached.


#94

Usually you can override these warnings.

BTW, these AV programs are more a placebo anyway IMHO :wink:
And more insightful pros do think similar


#95

Agree. I disabled it and got it installed.
Error is gone, thanks.


#96

I know its really, really late for a reply but I wanted to post this for the next guy/girl.

Like Linux, you need some environment variables to define your proxy credentials. Our company uses E-Mail + Password to authenticate to the proxy. I find that I have to URL Encode both my E-Mail and password due to symbols. The @ sign in the E-mail address will break the string early. Anything after @ = proxy server address:port.
User: Jim.Tom@something.com
Pass: $testing%

set HTTP_PROXY="Jim.Tom%40something.com:%24testing%25@Your-Proxy-Address.com.net.org:8080"
set HTTPS_PROXY=“Jim.Tom%40something.com:%24testing%25@Your-Proxy-Address.com.net.org:8080”

Another issue I had was that my proxy will mess with EVERY certificate. It inserts itself in every CA chain. It is a nightmare trying to browse with Firefox. For this reason, I received a TLS cert error because “SerialMonitor” needed to be compiled from source. There was no matching version for nodejs 5.4.1. To get around this error, add the following to npm config:

npm config set NODE_TLS_REJECT_UNAUTHORIZED=0

After adding that variable I received another error during SerialMonitor source compilation. This was due to having Visual Studio 2015 Enterprise. I had to update npm to a later version than what came with 5.4.1.

npm install -g npm@next

Add another npm config variable to specify VS 2015.

npm config set msvs_version 2015 --global

After all of that it is working now. At home it was a 5 minute install. At work it was half a day.