Timeline on RC26 Support for Workbench


#1

Hi all,

I’m merrily poking away at my Argons, but I need support for the second I2C channel, hence RC26. Due to a couple odd work issues, I can’t currently connect them over WiFi, and have been using Workbench to program them. Is there a timeline for when Workbench will list RC26 as a possible compile target? I additionally need the local compiler, as the online SdFat library isn’t compatible with the mesh units yet. I know I’m a bit of an odd case right now, but hopefully there’s something coming?


#2

You can also cloud compile with local libraries via CLI.


#3

Thanks, ScruffR, didn’t realize that. Right now the CLI is still using online libraries, I’ll have to poke at it a bit more… Probably to do with how I added the libraries.


#4

You can use particle library copy to download a copy of the library into the lib subfolder or when you have a local copy already, just place it in the ./lib/libName/.


#5

Hmm, tried that, it’s copied the library files into the lib folder (basically overwrote what I had in there, no problem, expected it and redid the minor changes I need). Unfortunately, when I compile, it’s still using online libraries (basically, I’m getting the errors I see when it uses the standard, unmodified SdFat library). My project properties are as follows:

dependencies.RTClibrary=1.2.1
dependencies.SdFat=0.0.7
dependencies.clickButton=1.0.9

Not sure how to force it to use the local library for SdFat. The other two don’t really matter, I haven’t modified them.

Thanks for your help, really appreciate you taking the time to look at this!


#6

You need to remove the dependencies line from project.properties. It will upload and use the local version in the lib directory. If you leave the dependency in, it will use the published version instead of your local version.


#7

Perfect, that did! Thanks very much to both of you!


#8

Sorry guys, one more just to be a pain. I need the Wire1 second I2C channel, so I need to build against rc26. I’m using the CLI command ‘particle compile argon --target 0.8.0-rc.26’ but I’m still getting error: ‘Wire1’ was not declared in this scope, which I thought was fixed in rc26 (bugfix #1633). Just to make sure it wasn’t something wonky in my code, I tried running the hyper-basic example out of the bugfix, which also failed. Any thoughts?


#9

This should be fixed now, we’ve had an issue with cloud compiler. Please try once again to see if you can still reproduce the issue.


#10

Is there a timeline for when Workbench will list RC26

SOON :wink:


#11

Hi avtolstoy, it’s indeed fixed now. Thanks!


#12

+1