Spark/flash/status FAILED on OTA

Hi all

I’m using the Particle dashboard with a product to flash OTA application updates.
I’m finding that I consistently receive the spark/flash/status ‘FAILED’ message while watching the logs, just after updating a customers product.

Now, the update appears to be successful, for the most part, although I’m experiencing issues with one of my products behaving differently when it should be running the same firmware as the others - definitely at least ‘part of’ the update has worked as the customer tells me on-screen elements have updated. So my first question, is it feasibly possible that you could have part of an update work, but also some corruption in the transmitted .bin file? Or is the checksum process good enough for this to be impossible, or very unlikely? (I’m not blaming the OTA system yet as it could be my own bug - just wanted to check on that question).

My second question is, is it a normal phenomena to see the ‘FAILED’ message after trying to OTA, or does that indicate something wrong in my process? I’ve seen a few related posts asking about this but haven’t seen a sure answer.
To confirm I am setting the following just under my #includes in main.cpp so that part of it should be ok:


To answer half your questions :wink:

The failed response is a known issue, that was introduced by pulling a dashboard “upgrade” back that had unexpected side effects. Once the “upgrade” can be pushed again, the failed issue will (should ;-)) go too.


Thanks @ScruffR I’m definitely aware of the ‘will (should ;-))’ scenario!

1 Like

I was seeing this same problem (Code flashing correctly, but status ‘failed’), good to know that it’s being worked on!