[SOLVED] Install error in ATOM when installing particle-dev-local-compiler dependencies

Hi, I can’t seem to install theParticle Dev Local Compiler

Where am I going wrong?

It looks like you are using node version 0.10.40, which is way too old. Try updating to node version 6.4.0. https://nodejs.org/dist/v6.4.0/node-v6.4.0.pkg

Also, if you want to build locally, I would recommend using po-util. It’s a tool that I created that automatically installs all of the dependencies for you, makes it easy build firmware locally, and helps you flash firmware to devices via dfu-util or over the air using particle-cli. For more info, please check out the GitHub repository.

Po-util can be installed by doing:

curl -fsSLO https://raw.githubusercontent.com/nrobinson2000/po-util/master/po-util.sh
./po-util.sh install

I have a similar issue with installing the meta package on Atom

I do not know why it says node v0.10.40 because i have 6.4.0 installed.

Also apm --version shows atom is using v0.10.40. How would i get atom to use the latest version?

Here is something that @suda posted a while ago: It’s for Linux, but I think it can be adapted to work on Windows.

I don’t have experience with Windows, so I would recommend asking @suda for help with Particle Dev.

Thanks! the export command is not recognized though.

@suda can you help?

The SET command should do the trick in Windows.


set worked but the error still exists.

@ali this might help: https://github.com/spark/particle-dev/issues/152#issuecomment-239474196

Thank you @suda that worked!

1 Like

Sorry for late reply,

thanks for suggestion

getting this

please advise

AGMBP:po-util andygraves2$ ./po-util.sh install
.bash_profile present.
.bashrc present.
alias po="~/po-util.sh"
po alias already in place.
Installing Particle firmware from Github...
fatal: destination path 'firmware' already exists and is not an empty directory.
Installing Brew...
It appears Homebrew is already installed. If your intent is to reinstall you
should do the following before running this installer again:
    ruby -e "$(curl -fsSL https://raw.githubusercontent.com/Homebrew/install/master/uninstall)"
The current contents of /usr/local are bin Cellar CODEOFCONDUCT.md CONTRIBUTING.md cuda etc git include lib Library LICENSE.txt opt README.md share SUPPORTERS.md .git .github .gitignore
Already up-to-date.
Installing ARM toolchain...
Warning: px4/px4/gcc-arm-none-eabi-20150925 already installed
Warning: dfu-util-0.9 already installed
Installing Node.js version v6.4.0...
installer: Package name is Node.js
installer: Upgrading at base path /
installer: The upgrade was successful.
Installing particle-cli...
npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegExp DoS issue
/usr/local/bin/node-pre-gyp -> /usr/local/lib/node_modules/node-pre-gyp/bin/node-pre-gyp
/usr/local/bin/npm -> /usr/local/lib/node_modules/npm/bin/npm-cli.js
/usr/local/bin/particle -> /usr/local/lib/node_modules/particle-cli/bin/particle.js
/usr/local/bin/serialport-list -> /usr/local/lib/node_modules/serialport/bin/serialport-list.js
/usr/local/bin/serialport-term -> /usr/local/lib/node_modules/serialport/bin/serialport-terminal.js

> serialport@4.0.1 install /usr/local/lib/node_modules/serialport
> node-pre-gyp install --fallback-to-build

[serialport] Success: "/usr/local/lib/node_modules/serialport/build/Release/serialport.node" is installed via remote
- balanced-match@0.3.0 node_modules/npm/node_modules/node-gyp/node_modules/glob/node_modules/minimatch/node_modules/brace-expansion/node_modules/balanced-match
- concat-map@0.0.1 node_modules/npm/node_modules/node-gyp/node_modules/glob/node_modules/minimatch/node_modules/brace-expansion/node_modules/concat-map
- brace-expansion@1.1.3 node_modules/npm/node_modules/node-gyp/node_modules/glob/node_modules/minimatch/node_modules/brace-expansion
- minimatch@2.0.10 node_modules/npm/node_modules/node-gyp/node_modules/glob/node_modules/minimatch
- glob@4.5.3 node_modules/npm/node_modules/node-gyp/node_modules/glob
- lru-cache@2.7.3 node_modules/npm/node_modules/node-gyp/node_modules/minimatch/node_modules/lru-cache
- sigmund@1.0.1 node_modules/npm/node_modules/node-gyp/node_modules/minimatch/node_modules/sigmund
- ansi@0.3.1 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/ansi
- delegates@1.0.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/are-we-there-yet/node_modules/delegates
- are-we-there-yet@1.1.2 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/are-we-there-yet
- lodash._baseslice@4.0.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash._baseslice
- lodash._basetostring@4.12.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash._basetostring
- lodash.tostring@4.1.3 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad/node_modules/lodash.tostring
- lodash.pad@4.4.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.pad
- lodash._baseslice@4.0.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash._baseslice
- lodash._basetostring@4.12.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash._basetostring
- lodash.tostring@4.1.3 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend/node_modules/lodash.tostring
- lodash.padend@4.5.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padend
- lodash._baseslice@4.0.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash._baseslice
- lodash._basetostring@4.12.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash._basetostring
- lodash.tostring@4.1.3 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart/node_modules/lodash.tostring
- lodash.padstart@4.5.0 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge/node_modules/lodash.padstart
- gauge@1.2.7 node_modules/npm/node_modules/node-gyp/node_modules/npmlog/node_modules/gauge
- npmlog@2.0.4 node_modules/npm/node_modules/node-gyp/node_modules/npmlog
├── node-pre-gyp@0.6.29 
├─┬ npm@3.10.6 
│ ├─┬ glob@7.0.5 
│ │ └── minimatch@3.0.2 
│ ├─┬ node-gyp@3.4.0 
│ │ ├── minimatch@3.0.2 
│ │ └─┬ path-array@1.0.1
│ │   └─┬ array-index@1.0.0
│ │     └─┬ es6-symbol@3.1.0 
│ │       └── es5-ext@0.10.12 
│ ├── npm-user-validate@0.1.5 
│ └── rimraf@2.5.3 
├── particle-cli@1.16.0 
└── serialport@4.0.1 

Sucessfully Installed!
AGMBP:po-util andygraves2$ po
-bash: po: command not found
AGMBP:po-util andygraves2$ po-util
-bash: po-util: command not found

Sorry for the confusion. The po command is added to your ~/.bashrc, so you must open a new terminal window to use po-util. Also, your ~/.bashrc is loaded by your ~/.bash_profile, and if it is incorrectly written, the ~/.bashrc might not be loading. Check your ~/.bash_profile, it should look like this, or have this in it.

    if [ -f ~/.bashrc ]; then
        . ~/.bashrc
1 Like

i got this error today and i haven’t changed anything or installed any new versions.

Error compiling Less stylesheet: C:\Users\***\.atom\packages\particle-dev\styles\particle-dev.less
Line number: 8
'utilities.less' wasn't found

Thanks for the guidance,
po-util is running.
What editor do you advise?

I just use Atom. One of the packages I love using is terminal-plus. It lets you have a terminal window inside of Atom, so that you can write your code and and have a terminal window right below it that you can use po-util inside.

1 Like

I’m getting the same error on OS X.

I’m on node 4.4.0.

What is apm?

I can’t really follow the steps Ali used to solve the problem.

Try installing the latest version of node on your computer.

Apm is how Atom installs packages.

Now on node 4.5.0 but running Particle Dev gives same error.

You can use the code on this page to get it working

Go into the folder where atom is installed, into packages and particle dev, there do all that it says above and in the link and it should work.

Thanks for all the help!

Turns out I didn’t have Atom installed. Only have ever installed Particle Dev, so there was no actual Atom (or it was not where it should be).

So I installed Atom directly from www.atom.io

Then installed the Particle packages and was able to get the particle-dev-local-compiler installed. So I have the new compile button and downloaded the firmware versions and can select the correct firmware version.

Making progress.

When I select my firmware version and attempt to compile my app I get:

Is there a fix for this?