Sending special characters via webhook

I’m using an Electron to trigger a webhook, which gets to twilio to send a sms message. I’d like to put a line break (0x0A) in the sms - Twilio suggestion is to put a %0A (linefeed) in the body section of the query, as in (code snippit via Twilio):

$ curl -X POST{AccountSid}/SMS/Messages.json \
-d "To=%2b14154445555" \
-d "From=%2b14156667777" \
-d "Body=Here+is+my+first+line%0aHere+is+my+second+line" \
-u '{AccountSid}:{AuthToken}' 

In my firmware, I am doing (currently- there’s been a few other attempts):

        data_out+=String(0x10, DEC);
        Particle.publish("webhook", data_out);

And the relevent section of the query part of the URL the webhook is posting:


I’ve tried Line1%0ALine2" and get “Line1%250ALine2” in the URL… I’ve tried “Line1%0ALine2”…

Apologies if this is a simple question, but I’m stumped. Anyone have any help?

As I thought, the answer is as simple as me misreading the documentation - String(int, base) doesn’t act like I thought it did. Changing to

Works way better.