Reading current draw of spark core

I bought a multimeter , i set the red wire to 10 A and choose 200ma (Dc)
i grounded to com. Then i pluged battery 6v , red to red (multimeter) to vin and black to black (grnd)
The batteries went hot like hell and the reading was wrong ! and the core led shutdown .

Note : Without even pluging the core the multimeter reads 30 ma
what am i doing wrong ???
Thanks all ( i need to know the code current draw)

I’m not clear of your wiring… If you are measuring current, it should be

_+__ <------> red (multimeter) -----------> black (multimeter) -----> Vin
Battery
_
-__ <------------------------------------------------------------------------> Gnd

It sounds like you short circuit your battery instead…

1 Like

I just did another way now .
I pluged usb there
and i put
Vin —> red multimiter (red)
grd --> com multimeter (black)

When i put multimeter to Voltage it read 4.5 v (which is right)
When i put the multimeter to 200 ma to read current the multimeter gives me 2.12
but the spark core stops led and restart itself

STOP WHATEVER YOU ARE DOING?!

@Gentmat, you need to understand how a multimeter works before attempting further.

To measure current, you need to be in SERIES and not just putting is across the Vin and GND!

What you are doing is to short the power supply together!


I really advice that you read up about how to use one or consult the manual before you damage all your cores and power supply… :broken_heart:

Recommend that you read this https://learn.sparkfun.com/tutorials/how-to-use-a-multimeter :wink:

wow !! :frowning:
any video about the series thing .
I ve searched for arduino current draw multimeter and didnt come up with anything

you’ve probably blown the fuse in the multimeter in that case.

I meant when i plug the multimeter to the battery .
But the battery isnt connected to the core . So the current must be 0 in my mind because the battery isnt attached to any device . thats what i meant

Now i understood it . i watched this video i ll paste the link so a noob like me can learn

So the idea is The red of multimeter goes to red
then the black continue the circuit by also connect to red .
watch the video guys (in case you need help like me)

Sej and kenneth thanks a lot guys

2 Likes

yeah, generally when unconnected multimeters read >0 current, they’ve blown their fuse. i had one that read 200mA when the leads weren’t even plugged in!

anyway did you get it working after watching the video? the spark should use 35mA when asleep and 350mA when awake. i never managed to get an accurate reading in deep sleep, it still said 35mA which isn’t right, it should be a lot less.

I got it working yes .
wifi is on 186 ma
sleep is 35 ma
I ll try deep sleep now and tell you the current

LOL , i made a sleep in the loop , and then i said i ll reset to check it out . seems im stuck and im trying to reset to factory with no help . i ll retry in a hour or se

that’s what i got - when i tried to measure deep sleep current it wouldn’t wake again and i had to factory reset, and i never got a reading under 35mA

We did a bunch of testing over here and using a very precise multimeter I found the current during WiFi communitcations to be 145mA, and in deep sleep it was 187uA.

1 Like

Well my deep sleep is 145 with wifi , 35 sleep mode, 2 ma deep sleep All of the following without any sensor

Sounds fair, but what kind of current measurement accuracy does your meter have? Unless it’s a really expensive one, it’s probably not going to measure microamps very well and will show up as more than a milliamp.

I think its fair enough ! it can show ua .

YEP if i wait a bit am having around 184 :smiley:

but if i put multimeter on 200 Ua it doesnt work ( its chinese ) :smiley:
When i put it on 200 ma i am geting 01.8 which is like you i guess

1.8 on 200mA scale would be 1.8mA though, not 184 uA. It would have to read 0.184, is that what you meant?

I did the sleep Function to compare the sleep current draw now i ll write the exact current.

On multimeter 200 m
wifi on : 145.5
deep sleep : 02.1

On 2 A multimeter
wifi on : .143
deep sleep : .001

So am i geting amps or ua !! sorry im lost :smiley: and why would i have amps and you UA (less then me)

Can you please share the code you used to check the core current consumption in deep sleep mode. I need to be sure i am not doing something wrong . 2.2 ma is huge comparing to 187uA my project depends a lot on consumption of current :smiley:

I tried with usb power , and i tried with 6v battery connected to vin and grd same results

The code I used is here… but takes a little bit to setup a webhost with a php script:

If you don’t have that you could probably just change the GET request to this:
https://www.google.com/search?q=uyureowiuweurueoiwyuer

which returns a very minimal response… basically it can’t find that on google.

char srvIP[] = "www.google.com";
char srvHost[] = "www.google.com";
int srvPort = 80;
char srvPath[] = "/search?q=uyureowiuweurueoiwyuer";

Note: I just changed the svrIP[] to a host name… you could easily just replace srvIP[] with srvHost[] in the code and delete srvIP[] altogether.

Code defaults to 1800 seconds deep sleep (30 minutes)… you may want to lower this initially to something like 30.