Programmer Shield and Electron

Trying to debug and flash an electron using the programming shield and am failing to connect to the device. I’ve got the electrons D7-D3 aligned correctly in the socket as the same with the photon.
Tried with a photon and it is successfully working (Both in DFU mode).

Should I be differentiating the command depending on the device or should the same command work on both Photon and Electron?

Using the following command

openocd -f interface/ftdi/particle-ftdi.cfg -f target/stm32f2x.cfg -c "gdb_port 3333"

and am getting the following error

Info : auto-selecting first available session transport "jtag". To override use 'transport select <transport>'.
adapter speed: 1000 kHz
adapter_nsrst_delay: 100
jtag_ntrst_delay: 100
none separate
cortex_m reset_config sysresetreq
Info : clock speed 1000 kHz
Error: JTAG scan chain interrogation failed: all ones
Error: Check JTAG interface, timings, target power, etc.
Error: Trying to use configured scan chain anyway...
Error: stm32f2x.cpu: IR capture error; saw 0x0f not 0x01
Warn : Bypassing JTAG setup events due to errors
Error: Invalid ACK (7) in DAP response

I think the Programmer Shield should work with the Electron, but I never tried it.

I always use the inexpensive ST-LINK/V2 clone SWD sticks with the Electron. They’re really cheap and only require access to 3V3, GND, D7 and D6.

1 Like