Photon Worked - Now it Doesn't "Photon-AWBS" - what is that?

Hi All,

I have a Photon which has been working great in a development effort I am pursuing. I have uploaded my code into it many times and (unlike Sparks used before it) updates almost never fail == progress!!

Yesterday, I received one of those cheapy RFID readers (RFID-RC522) and decided to hook it up to this working Photon to do a quick try out. Having skimmed through the discussion about that here

I included the library “MFRC522/MFRC522.h” in my code and added the suggested basic init and read examples from the library h file - seemingly all simple. I decided that it would be fast and expedient to leach the 3.3v for the reader from the Photon so I connected it up as per the very helpful forum discussion - but took the 3.3v from the Photon (that reader needs 3.3v at about 7ma so far as I can find out).

Thereafter the photon won’t program any more no matter what I try :worried:

So, today I decided I would do a full reset on the board and re-claim it using the phone method. Tried to do that this evening, but having un-claimed the board, I reset the board (hold down Setup - not “Mode”? as it says on the Photon app - Android version) and looked for my board, all I see is something called “photon-AWBS” - which IS my board cos it goes away if I power the board off. If I connect to that, the Photon app thinks hard for about a minute and eventually gives a non-commital error.

So, question: Have I fried the 3.3v supply on the board by overloading it? I still have a healthy 3.33v on that pin, so puzzling if so, OR has the addition of the library to my code base (or an incomplete upload of same) butchered the firmware in some fatal way, has my core been invaded by gremlins or virus… or… ??

I’m thinking I may have to USB connect this device to do a deep deep reset on it - but trying to avoid that as never had to go that far before…

Does anyone know what is “Photon-AWBS”? Google turns up nothing. Any help greatly appreciated.

Best regards
Alan T
Cornwall UK.

Have you tried putting the device into Safe Mode?
Have you tried flashing via USB?

In such cases unclaiming hardly ever does any good for troubleshooting.
The only thing that might help is clearing the WiFi credentials to get the thing hooked back up to your network, but don’t unclaim the device for something like this.

But since you’ve already done that, you need to reclaim it and I’d go with CLI for that.

  1. remove any external circuitry
  2. flash known good code (e.g. particle flash --usb tinker)
  3. get the thing hooked back up onto your network (e.g. particle serial wifi with no auto-scanning, but manual)
  4. retrieve your device ID (e.g. particle identify)
  5. claim the device ( e.g. particle device add <insertDeviceIDfromStep2>)

That is known as SoftAP (you’ll find that term in this forum) which turns the Photon into an AccessPoint to directly connect to it from any WiFi enabled device (providing it’s 2.4GHz) to talk to the Photon (and in this case send WiFi credentials to which it should connect after falling out of SoftAP mode).

AWBS are just the four last letters of the “serial number” of your Photon, which should be printed on the box the device came in :wink:
Another Photon in Listening Mode will also act as AP but be called slightly differentPhoton-xxxx

Without any special SoftAP firmware flashed, you can connect to that network with any browser at the IP reported as Standard Gateway in your network properties and get a “Hello” message.

Hmm, if you were trying to do a factory reset, then that’s not going to work since the photon doesn’t have that.

Connecting over USB is not that ‘far’, and used quite a lot while serial debugging. It can be a really useful tool!
Though you might want to try USB regardless, you might not (yet) have to resort to that. Rather, place your device in safe mode. If you’ve reset the credentials, it will go into blinking blue, asking for new credentials, at which point you can provide those using either the app, the CLI, or a serial terminal. Then, if that connects and goes into breathing magenta (safe mode) you can try flashing it again with a preferably known good firmware like Tinker or Blink an LED.

Alternatively, take the steps mentioned by @ScruffR above and use the CLI :smile:

1 Like

Hi guys thanks for all the replies. Clearly you all agree that my Photon needs a full reset. Can anyone venture an opinion as to causes - was it the RFI library that I added - no record I can find of it breaking anyone else’s device - perhaps I was just unlucky?

Started doing the CLI install this morning - and just remembered why I never did it before - doing it on Windows is truly like obstacle course! Seems a lot easier on OSX - which I don’t use - and I can’t find any mention anywhere of a Linux/Ubuntu install? Is there one?

So here I am mid-way through the labyrinthine Windows install process … I’ll let you know how it goes. Hope my clue of thread lasts out so I can get back to the start if I need to :slight_smile:

This is probably too late to help you, but there is a now a nice Windows installer for the CLI that takes care of the process for you.

1 Like

Many thanks guys. I eventually used the simple installer to get my CLI install done (It would be great if on the particle reference pages the convolute old method could be replaced - it would have saved me an awful lot of time and dyspepsia!). However, even with the CLI installed, I still could not get this Photon to reset or talk to the CLI. In the end, I unpacked another Photon I had and went through exactly the same sequence as before (the RFID thing I described above) and all was sweetness! All I can think is that my old Photon must have reached a hardware failure point that coincided with my adding the extra code and module? Anyway, all okay now - so many thanks for all the help.

Alan T.