[Particle Official] Windows 10 Full CLI and DFU Setup

In the folder the file has a .sh ending, which after I did some Google research found out it is a Linux executable file. I am a complete beginner to everything in this tutorial (including the spark core) so I will be asking some very basic (dumb) questions so feel free to correct me wherever I am wrong. In order to get build-mingw32-libusb.sh to do anything when I click on it I downloaded Cygwin to my Windows 10 machine and managed to get a prompt window to open briefly and close. I had to leave for work this morning shortly after getting that far so I will report back if I am still lost.

Actually you won’t need that file.
There should be a folder with already prebuilt Windows executables called win32-mingw32
Just copy all the files in this folder to your desired location (the one you added to your PATH).

1 Like

Was able to perform a deep update on the core and was successful in claiming the device through the CLI. Thanks for this guide and input from everyone else, I appreciate all of the help.

1 Like

I have just gone through loading node.js, npm, particle cli, zadig on a new Windows 10 Home laptop. All seemed to go well and I loaded node and npm and particle cli and logged in. Then I setup the usb-serial and dfu-util. Then I came out of the shell/command prompt and left the PC. When I came back it does not recognise the Particle command and if I try to re-install I now get a warning

npm WARN deprecated minimatch@2.0.10: Please update to minimatch 3.0.2 or higher to avoid a RegEx DoS issue

It appears to carry on through the install OK but the particle name is still not recognised as a command. What is happening?

Have you restarted your PC to ensure the PATH extension got in effect properly?

Yes I have. It was after the restart that the problem was exhibited. Not sure how to sort this out now.

Have you tried the installer yet?
https://binaries.particle.io/cli/installer/windows/ParticleCLISetup.exe

@Moors7 I hadn’t tried the installer. I have just tried. Download OK and all appeared to be going well until I got an error message - however, this was due to the wifi network (I am in a hotel with cr*p wifi) - I will try again tomorrow and hopefully no timeout message. Thanks again.

Managed to get it to work - Thanks.

1 Like

I’m also having problems setting up on win10 - I reported the basics elsewhere


Since then I followed all the suggestions in this list, including running
ParticleCLIsetup.exe
And still getting the same result for:
particle setup running in a "Adminstrator: PowerShell"
PS C:\Users\neilh77\Downloads> particle setup
Error loading command C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\commands\SerialCommand.js Error: Mo
dule version mismatch. Expected 48, got 46.


| '_ \ __ _ _ __| |() | | ___
| |
) |/ _` | '
| __| |/ | |/ _
| /| (| | | | || | (| | /
|| _,|| _||_
|_|_
|
https://particle.io

Setup is easy! Let’s get started…
It appears as though you are already logged in as XXXXX
? Would you like to log in with a different account? No

! PROTIP: Hold the MODE/SETUP button on your device until it blinks blue!
! PROTIP: Please make sure you are connected to the internet.

readline.js:982
throw err;
^

TypeError: Cannot read property ‘findDevices’ of undefined
at SetupCommand.findDevice (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\commands\SetupCommand\ind
ex.js:293:8)
at accountStatus (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\commands\SetupCommand\index.js:150:
3)
at switchChoice [as completed] (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\commands\SetupCommand
\index.js:115:4)
at PromptUI.onCompletion (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\node_modules\inquirer\lib\u
i\prompt.js:57:10)
at AnonymousObserver.Rx.AnonymousObserver.AnonymousObserver.completed (C:\Users\neilh77\AppData\Roaming\npm\node_mod
ules\particle-cli\node_modules\rx-lite\rx.lite.js:1550:12)
at AnonymousObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (C:\Users\neilh77\AppData\Roaming\np
m\node_modules\particle-cli\node_modules\rx-lite\rx.lite.js:1489:14)
at Subject.onCompleted (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\node_modules\rx-lite\rx.lite.
js:5871:19)
at Subject.tryCatcher (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\node_modules\rx-lite\rx.lite.j
s:63:31)
at AutoDetachObserverPrototype.completed (C:\Users\neilh77\AppData\Roaming\npm\node_modules\particle-cli\node_module
s\rx-lite\rx.lite.js:5796:56)
at AutoDetachObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (C:\Users\neilh77\AppData\Roaming\n
pm\node_modules\particle-cli\node_modules\rx-lite\rx.lite.js:1489:14)
PS C:\Users\neilh77\Downloads>

I can’t see the pictures :frowning:

Neither can I. I’ve passed it on to the team, and they should take a look at it when the sun comes up again over there :wink:
You should be able to follow the steps without the images though. Let us know if you need assistance.

1 Like

I’m not seeing the pictures as part of the tutorial. Is that me, or have they disappeared. thnks

[Particle Official] Windows 10 Full CLI and DFU Setup :wink:

FYI I’m commissioning a new Photon to go into an evolving new design and its been painful.
Eventually this was what helped me on an Ubuntu 16.04


Previously I’ve purchased Photons possibly 2015, tested and started using them - with a very attractive feature being an easy commissioning into a secure WiFi network. Firmware on the device 0.5.2 I think
I commissioned my first Photon with my Android Nexus 5, Particile app and it worked.
Subsequentially last yea 2016 Nov I commissioning another Photon - and the App failed, so did the Windows 10 - a misearble experience I documented but got it working in a way I didn’t document.
Its been reliable reporting to https://thingspeak.com/channels/159634

I tried commissioning a photon yesterday - and a miserable 4hour experience with tutorials that just don’t work the way advertised - Android App and particle/Windows10,
Eventually it worked with bringing in tools on an older ethernet networked Ubuntu 16.04 and finding a few commands to do it


So now I’m supposed to have customers have an Ubuntu machine to commission into a secure WiFi network?
So just some feedback that the tutorials have proliferated, but missing something for working in the real world, with real world devices. My ideal is that it would be easy with a browser based smart machine to enter network credentials - the Photon App concept is ideal, but I would hope there is a full proof fallback.

Over time other easier ways to get the job done have been incorporated

e.g. the SoftAP feature that allows you to connect to the device itself via 192.168.0.1 on any browser, or via https://setup.particle.io

And I’m convinced Particle will still be investigating and introducing even easier routs till we hit v1.0.0

I really appreciate the Photon - also appreciate that it takes a diverse set of skills to make it all happen. So thanks for the info. I do have an Electron and will look at trying that on a beta piece of my hardware soon.

When I open the Particle CLI command window it closes when I try to type something in. Any thoughts?

I am running Windows 10 and used the windows cli installer.

@Allan, not sure which “Particle CLI command window” you are referring to. Open any Command Prompt window, ideally with admin privileges. Make sure you are not in the system32 directory when doing so. Once in the command prompt window, type “particle” and it should work. I customized a copy of the command prompt shortcut to open the prompt in a specific directory (where all my projects are) and with admin rights.

Oh, that worked thanks!

1 Like