P1 blinking Cyan with Red after instaliing bootloader using ST link


I have one application with RAM used 59KB of 81KB.

If by mistake i forget to change location from “0x08000000” to “0x080A0000” for my application program then it crash P1 so only dim blue led.

After that i tried to install bootloader and system part-1 and system part-2 file of version 1.0.0. using st-link utility, It installed correctly and now RGB led is blinking blue so it is in listen mode as fresh device.

After that if i try to connect with wifi using serial then wifi also configured successfully but now P1 blinking cyan with red. To solve this i have to do “particle keys doctor” and then it works.

If i am using any other application code with less RAM used and follow same step then in that case P1 is blinking cyan perfectly.

Please guide me how can i program bootloader of P1 without this issue.

Thank you.

If you have USB (as I’d deduce from your statement *“connect with wifi using serial”`) then the easiest would be to do it via Listening Mode and

particle flash --serial <bootloader.bin>

No need for ST-Link (for other system parts neither).

When you flashed the image to 0x08000000 you overwrote the configuration flash sectors. This erased your Wi-Fi credentials, and also your device keys. That’s why you needed to particle keys doctor. The blinking cyan with red blinks is often a keys error.

1 Like

When P1 crashed, at that time not able to enter in Listen mode so i cannot program bootloader using serial.

Yes. i think it is erasing configurations. To cross check before programming specific P1 i saved configuration in one file using stlink(at location 0x08004000) and when installing bootloader at that time i also programmed this configuration file so in that case after connecting with wifi it is working. No red blink.

But in one of my device, i never claimed on particle and in that P1 OS crashed so tried same step with “particle keys doctor” but for specific that module it give error message like “Make sure your device in DFU mode or your pc is online” Same case like this Post

So i can solve issue for device which is already claimed on particle but any idea about what if device is not claimed on particle?

As long as you don’t erase the configuration, you should not need to particle keys doctor. Make sure you don’t write to 0x08002000, basically.

Otherwise, as long as you update the bootloader, system part 1, system part 2, and user firmware (or Tinker) by JTAG/SWD you should be fine.

Ok. Thanks.

Any idea about how i recover this device?


Make sure the bootloader and system-part1 and system-part2 versions are matched properly. That should allow particle keys doctor to work.

In rare cases you may need to erase both configuration flash sectors by JTAG/SWD, but that shouldn’t normally be necessary.

Ok bank 0, sectors 1 and 2 (starting at 0x08004000 and 0x080008000). Right?


Ok i think printing mistake in this doc

It should be 0x8008000.

Ok I will try with unclaimed device by erasing first this two sector and then particle keys doctor command. Because in unclaimed device, this normal procedure is not working.

Thank you.

1 Like