OTA update device at version 0.6.2 shows Success but nothing uploaded

I have been trying to OTA update my devices using the CLI and the below command:

particle flash “ID” file.bin

I can see the progress through the console stating: Started and Success.

But the device restarts and keeps using the old firmware.

I also tried flashing with: particle flash “ID” tinker and this also shows success but then restarts with the old firmware.

Does anyone know why the updates are not going through?

Sorry for asking the obvious; how do you know your firwmare is not updated? Do you have a version number you can check? (or something else that is unique to your new code like a LED pattern or pin flip)

When you see the FW download finishing, do you see the particle device LED flashing an SOS error or is all well?

I have the device next to me to check which has a TFT screen showing the version.

You can also see the version through the Console.

And no error codes of any kind?

Can you hook up a usb and flash the device with dfu-util?

Is the device part of a product? Unless it’s marked as a developer device as soon as it reboots after you flash it manually it will get reverted back to the released product firmware or lock and flashed firmware.

You can also submit a support ticket. Be sure to include the device ID so the cloud logs can be checked.

Also double check your binaries. For the firmware binary file:

particle binary inspect firmware.bin

Make sure the platform is correctly set.

Also you can check the device in listening mode after flashing to see if there’s anything unusual:

particle serial inspect

Have you tried updating the bootloader?