OSX Particle CLI install trouble!


I have just received my first two Particle Photon’s in the mail and am currently just going through the particle.io/start/ tutorial.

I am currently trying to install the Particle CLI on OSX, but I keep getting errors. I have already solved some of them, but one error only leads to the next.

Now it’s telling me I don’t have priviliges/admin rights along the way of executing the install command:

sudo npm install -g particle-cli

Could someone help me out, because I’m not quite the terminal wiz. See what happens in the terminal in the link down below.


Thanks in advance!


EDIT: I just solved the install problem, turns out I had to start Xcode to agree to their license! Now, when I run:

particle setup

I get the following two errors first, before it runs the command:

Error loading command /usr/local/lib/node_modules/particle-cli/commands/CloudCommands.js Error: Module version    mismatch. Expected 47, got 46.
Error loading command /usr/local/lib/node_modules/particle-cli/commands/SerialCommand.js Error: Module version mismatch. Expected 47, got 46.

Anyone knows what to do about these?

EDIT2: Turns out that trying to log in crashes aswell:

TypeError: Cannot read property 'login' of undefined
at login (/usr/local/lib/node_modules/particle-cli/commands/SetupCommand/index.js:261:7)
at PromptUI.completed (/usr/local/lib/node_modules/particle-cli/commands/SetupCommand/index.js:143:19)
at PromptUI.onCompletion (/usr/local/lib/node_modules/particle-cli/node_modules/inquirer/lib/ui/prompt.js:69:10)
at AnonymousObserver.Rx.AnonymousObserver.AnonymousObserver.completed (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:1793:12)
at AnonymousObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:1730:14)
at AnonymousObserver.tryCatcher (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:567:29)
at AutoDetachObserverPrototype.completed (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:5288:56)
at AutoDetachObserver.Rx.internals.AbstractObserver.AbstractObserver.onCompleted (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:1730:14)
at InnerObserver.onCompleted (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:3425:65)
at InnerObserver.tryCatcher (/usr/local/lib/node_modules/particle-cli/node_modules/rx/dist/rx.js:567:29)

Assuming you have admin rights, have you tried enabling Root User before you do the $ sudo npm install?

I assume you know how to do this - a quick google otherwise! :grinning:

If this doesn’t work there might be some other unix utility that needs to be setup. Not as straight forward as some make out. :confused: