Online IDE broken

I just recived my Particle Xmas shield and wanted to give it a spin, but when I try to select it in the online IDE, I get the following Javascript error:

application-b44f79e25ede280dd572c63053ffa8d4.js:75000 Uncaught TypeError: Cannot read property 'get' of undefined
at (application-b44f79e25ede280dd572c63053ffa8d4.js:75000)
at Class.trigger (application-b44f79e25ede280dd572c63053ffa8d4.js:21600)
at Class.superWrapper [as trigger] (application-b44f79e25ede280dd572c63053ffa8d4.js:3523)
at Object.handleEvent (application-b44f79e25ede280dd572c63053ffa8d4.js:24184)
at Class.handleEvent (application-b44f79e25ede280dd572c63053ffa8d4.js:23670)
at application-b44f79e25ede280dd572c63053ffa8d4.js:21340
at (application-b44f79e25ede280dd572c63053ffa8d4.js:7884)
at (application-b44f79e25ede280dd572c63053ffa8d4.js:8220)
at Class._bubbleEvent (application-b44f79e25ede280dd572c63053ffa8d4.js:21339)
at HTMLAnchorElement.<anonymous> (application-b44f79e25ede280dd572c63053ffa8d4.js:21283)
at Object.Ember.handleErrors (application-b44f79e25ede280dd572c63053ffa8d4.js:2860)
at HTMLAnchorElement.<anonymous> (application-b44f79e25ede280dd572c63053ffa8d4.js:21274)
at HTMLBodyElement.dispatch (application-b44f79e25ede280dd572c63053ffa8d4.js:6)
at HTMLBodyElement.y.handle (application-b44f79e25ede280dd572c63053ffa8d4.js:6)
at HTMLBodyElement.d (application-b44f79e25ede280dd572c63053ffa8d4.js:63474)

This makes it impossible to select anything but the current device. This will block anyone from playing with the Particle gear they got for xmas… :frowning:

It works for me, so I wouldn’t call it ‘broken’. Could you try refreshing your browser, incognito, or another browser in general to see if that makes a difference?

Worked just fine for me also.

Odd. It works now. That means my kids get to play around with programming the trees :slight_smile:

I did several reloads and I tried both Chrome and Safari (on OSX) and it failed in both.