Odd behavior: Shield Shield and Serial1/Serial2

I am building a rover (4WD/off-road) and it has 2 RoboClaw 2x30A motor controllers that I am manipulating via Packet Serial. After thinking the problem was a wiring problem for the better part of 6 hours, I finally decided to try something ridiculous: I took the Core out of the Shield Shield and put it back in a breadboard.

As if like magic, my TX/RX wires started working and my motors were humming, and my rover then escaped my grasp and drove into my puppy… But, that’s a story for another day.

The real heart of the question is this: Is there something that the Shield Shield does to the Core that prevents the normal use of Serial1.xxx and Serial2.xxx ? I tried every possible combination of Serial1 and Serial2 (Serial1 is TX/RX and Serial2 is D0/D1). I had my wires running from the D0/D1 (also labeled TX/RX on the Shield Shield) to my controllers.

I would like to be able to use the shield shield because it’s more durable and I’ve got nice mounting clamps for it, and would really like to not have to mount my breadboard inside my rugged vehicle.

In case you’re curious, here’s my motor self test (notice that I’m using the breadboard and not the shield shield): https://youtu.be/sqPHzoJr920

I guess you know already, but just to make sure.

The RX/TX pins on the Shield shield are refered to via Serial1 and Serial2 goes to the pins Digital #3 and #5 on the shield.
On the shield they are 5V, on the Core 3.3V.

I had my wires plugged into the RX/TX holes on the shield, and I was using Serial1. I tried every permutation of Serial1 and Serial2 with the RX/TX pins on the Shield shield - absolutely nothing worked, I couldn’t get any communication in either direction using Serial1 or Serial2 while using the shield.

The RoboClaw motors S1 and S2 pins are designed for servo wire bundles… could the controller really work with 3.3V serial signals and NOT 5V serial signals? These controllers are designed specifically to be downstream of Arduino Nanos and other microcontrollers.

Maybe you could try to whip up a test sketch for the Shield shield where you use Serial1 to talk to itself (TX -> RX) or to Serial2 (and back) and send debug outputs over Serial to your PC - without your other hardware.
This way you might find if the serial communication works at all.

You could also test your shield pins whether they have been frazzled somhow (digitalWrite() and digitalRead() work on RX/TX just the same).

You could also look here