Mesh still not stable


#1

Hi

I have 1 xenon as the gateway connected to the Ethernet with rest 5 in a single mesh network. All of them have been flashed to the latest firmware, but still after a few minutes I see red light on the gateway xenon. It flashes red for few minutes and then change back to slowly blinking blue.

Are there more updates coming ?


#2

There definitely are. Mesh is still pretty unstable.


#3

Hey abhishek,

We did just recently release rc26 to try and address a large number of issues we were seeing with Mesh reliability. That we can tell, many of them did what they were supposed to. With that said, we do recognize that we did not address all issues that users were having with Mesh.

Your issue sounds like it might be the documented “SOS 7” issue. In particular, when the device flashes red, it can flash an SOS pattern with a number of flashes after. You can see this detailed in our docs here.

This issue is acknowledged on our main topic for mesh issues at number 7.

Our firmware team is digging into this further and we hope to have some more information soon on next steps on how to proceed with this issue.

I want to assure you we are far from finished in releasing mesh updates. rc26 isn’t our last, nor will rc27 be. We are determined to keep iterating, getting feedback, and implementing fixes as needed until Mesh is stable and production ready.


Putting back in box (update: took back out of box...)
#4

Hey there!

Adding on to what @mstanley contributed – we just posted an update on our stability progress to date and where our focus is moving forward. I encourage you to take a read and contribute your feedback.

Gen 3 improvements update - 12/17

More specifically, we’re in the process of prepping a firmware release for the SOS-7 fix you described, which we’ve linked to an issue with the low level 802.15.4 driver from Nordic. We’ve worked with them to pull in the fix they provided and will make the rc.27 firmware available as quickly as possible.


#5

Hello folks,

Wanted to follow-up with this thread to let everyone know that a fix for the SOS-7 issue has been released with v0.8.0-rc.27. The issues was tracked to a problem with the Nordic 802.15.4 driver. Instructions for upgrading are available below. We’d love to know if applying the release fixes the issue SOS-7 issue that you’re experiencing.


Note that we have seen some reports of change in behavior for rc.27 when users call the Mesh.subscribe() function within the setup() loop that can result in a separate SOS-10 code which we’re currently investigating. If this issue affects you, please note the following workaround.