"make" doesn't compile my firmware

Hi guys,

I tried to setup a spark core IDE using this video-tutorial:

The build seems to be fine and I succeeded to upload the firmware to my core. I tried to change the application (application.cpp) but the firmware didn’t include my application. I did a “make clean” and make again, everything builds fine - even if I make some typos in the application. After flashing, the last application seems to run again?!

Do you have any idea what I’m doing wrong?

regards, Erwin

This may seem too obvious, but did you press save before make?

Hi @BDub,

you’re right, as I’m using an IDE (NetBeans) i double checked by pressing save and checking the saved file by an external editor.

I have my files in E:\SparkCore\src\core-firmware, the application.cpp used to be in src-folder, I run make and generated the firmware in the build folder,…

regards

ok, the “make” command failed to create the firmware correctly (values below “text” and “data” was zero). I did a git clone again and did everything again - now with success (text: 25240, data: 2904).

Thanks anyway!

It sounded like you’re application.cpp wasn’t being compiled and it sounded like you’d moved the application.cpp file and presumably not told make about it. If you need to move application.cpp you’ll need to modify the makefile.