Local cloud not connecting, persistent Cyan>Green>Red

Hello, I am trying to connect spark core to local cloud following this tutorial.
At the point where it should connect to the local cloud it is showing me this in repeat with cachekey and connId value changing : (core id is truncated as i wasn’t sure of security issues associated)

Connection from:, connId: 20
Expected to find public key for core 54ff70066667515134451467 at /home/amit/spark/spark-core/spark-server/js/core_keys/54ff70066667515134451467.pub.pem
1: Core disconnected: Handshake did not complete in 120 seconds { coreID: ‘54ff7006’, cache_key: ‘_15’ }
Session ended for _15
Handshake failed: Handshake did not complete in 120 seconds { ip: ‘’,
cache_key: ‘_15’,
coreID: ‘54ff700’ }

Core is just going through a cycle of blinking cyan, 2-3 blinks of green then red (not sure if red or orange, colour deficient :frowning: but only red point was blinking so i guess… )
(most of threads on similar topic were reporting connection and disconnection, but mine is not even connecting once)


your core is connected correctly or the handshake message will not appear.

the console is telling you that the key cannot be found

Expected to find public key for core 54ff70066667515134451467 at /home/amit/spark/spark-core/spark-server/js/core_keys/54ff70066667515134451467.pub.pem

1.) Check that you have the core public key in the core_keys folder

2.) Restart the server if you have done se

1 Like

THANKS!!! keys were there but for some reason thew were generated as "54ff70066667515134451467_new.pub.pem"
So i renamed it and lo! i now get the known error of repeating:

Connection from:, connId: 10
on ready { coreID: ‘54ff70066667515134451467’,
ip: ‘’,
product_id: 0,
firmware_version: 7,
cache_key: ‘_9’ }
Core online!

Never been so happy seeing some error! will start again now! Thanks


Known error of repeating? It’s already connected and online :smiley:

Really? But spark list shows core offline and core still blinks red. The above message of core online is coming again and again. But this had been reported in this forum so I will try sorting it after lunch. A Sunday morning well spent!

simply update tinker using spark flash --usb tinker via DFU. be sure to update Spark-cli to the latest version using npm update -g spark-cli

1 Like

It worked. I reflashed tinker and now its breathing cyan and my terminal is saying things like:

cache_key: ‘_564’,
duration: 692.326 }
Session ended for _564
1: Core disconnected: socket error Error: read ETIMEDOUT { coreID: ‘54ff70066667515134451467’,

but spark list was still showing core offline. So i did a reset and again went through “spark setup” now its just blinking green with no output in server window :’(

That’s for sessions for other connections that terminated.

1.) restart the spark-server

2.) flash the latest tinker firmware onto the core

3.) test again :wink:

Trying to :frowning: but it showing same thing again and again. let me try a clean dig from the beginning

HI again @kennethlimcp. shall i start another topic shall i continue on this one only as i am facing strange problem. but not sure if related to spark-server.
Followed the tutorial on windows and i think Local cloud is working fine as when i give spark setup and register my account i get - - [Tue, 24 Feb 2015 19:06:25 GMT] “POST /oauth/token HTTP/1.1” 200 115 “-” “-”

but no matter what, core keep on flashing green (can’t connect to wifi). My wifi settings are: Channel 10, mode 11b only, security WPA personal, encryption automatic(tried aes and tkip also but results were same)


it sounds like either:

1.) wrong server public key

2.) patching of CC3000 required.

Can you try them out?

1 Like

Sure. i will try it and get back soon. (by tomorrow i mean).

First of all sorry for such a long “tomorrow”!! was extremely busy. But i would like to confirm that after applying cc3000 patch i was able to connect to local cloud. One more problem i faced war of access rights to the “users” folder in spark-server. i need to run sudo node main.js to make it run properly (just FYI). I can now sent read and write commands from the terminal! (Tears of joy are streaming on my cheeks!)

Also i would like to ask few quick questions if possible:

  1. Now what? can i just compile binaries using web interface and flash with them? or they have to compiled on desktop?
  2. Just curious that you mentioned in one of the threads that “spark key doctor” is not available for local cloud. what does that mean? as i followed the blog here which uses the same command and it worked for me.