Library Include File Not Found Particle Dev

I am having trouble including libaries in Particle Dev for Windows. A minimalist example:

Today, I downloaded and installed Windows Particle Dev x64. I created a new project, TestLibraries. I added the library ntp-time 0.1.0. The TestLibraries.ino is:

#include "ntp-time.h"
// setup() runs once, when the device is first turned on.
void setup() {
  // Put initialization like pinMode and begin functions here.


// loop() runs over and over again, as quickly as it can execute.
void loop() {
  // The core of your code will likely live here.


The project. properties is:


When I compile this I get “ntp-time.h” not found.
Firmware 0.6.2 on a Proton.

This compiles fine if I copy the library to the project instead of adding it.

Suggestions appreciated.

And this from @suda… “It has not been yet included in the latest standalone Desktop IDE app but we’re working on it as we speak!”

I’m not using the stand alone IDE, I’m using the Atom based, compile in the cloud IDE.

This project compiles fine on the Mac version.

Me too…
sorry, wrong thread cite:

OK. I need to replace particle dev profiles. Where do I do that?

Update: I searched my disk for particle-dev-profiles and found C:\Users\djohnson\AppData\Local\particledev\app-1.18.0\resources\app\node_modules. I copied the 0.2.3 version to it and restarted Particle Dev. Still the same error.

Suggestions welcome.

The profile paths issue was fixed.
Using remote Particle libraries in the IDE doesn’t work currently and it’s being worked on.

There’s a beta/experimental local compiling IDE that runs in Docker, or you can copy the libraries to your local project folder and it will build properly. The downside to the latter is you push all your source for each build.

@suda is currently working on the remote library reference issue.

We’ve just released Particle Dev App 1.19.0 which should fix the “No such file or directory”. Let us know if this helped!

1 Like

Winner Winner, chicken dinner…:tada:

I can build w/remote libraries again. As a comparison, builds would previously run at just under 2 minutes with these projects, now I can build in just over 30 seconds.

Thanks @suda

1 Like

hello, i installed 1.19.0 and atom indicates that 1.19.0 is the latest build and gives a “no update available” message when i click “check for updates” but when i try to compile some code i get an error that states that a newer build is available that 1.19.0 is installed but 1.21.0 is available. sure enough 1.21.0 is up on github. is there any way within particledev to update atom or is atom code part of particledev.exe?

Hi Douglas, 1.19.0 is the latest version of Particle Dev App, our standalone IDE. It is usually a bit behind with Atom (hence the 1.21.0 suggestion in errors).
Can you post a screenshot of the error you’re seeing when compiling?

hello suda, here is a screen shot of the error. thank you for the reply.

oops, here is one with stack trace,

Oh that’s interesting! I think this is caused by the existence of a directory which name ends with .ino. Could you try renaming it so something else?

yes, that was the problem. this was my first attempt at bringing an originally arduino sketch into the particle build system and i think i got confused at some point of the process. thanks.

Good to know it works now. I created an issue to fix this.

well, if it makes the build product better then good ending to my mistake. btw, all the different arduino sketches and any related documentation i had habit of creating a folder with the sketch name and putting into a folder with all other sketches. what happened was i copied that particular sketch folder over to the particle dev without modifying the folder name. so, i spent some time this morning renaming about 60 folders taking that .ino out.

I would say that’s a good habit, just naming directories with extensions (like the .ino) might surface some bugs (like assumptions that if a file has an extension it can’t be a directory). Have you tried the Start new project command?

This would scaffold the whole project with metadata and preferred directory structure.

1 Like

actually, pressing the start new project was my first action. then i nested the .ino folder into particle dev. and did a quick compile to get an idea of how the sketch would work. then i looked at some docs and got the impression that having any sub-directories was not allowed. but i was looking at some examples and those appeared to have sub-directories. anyway, i hit that error and found the thread that i entered my question. i’m learning how it all fits together. which is a good thing. thanks for the replies.

1 Like