Large power draw, something miswired? [SOLVED]

I was previously running my neopixel at 3.7v so that I could use 3.3v logic. I just got an 8 channel logic level converter from adafruit so that I can run the neopixels at a full 5v. Problem is when I plug it in, everything lights up and the core goes breathing cyan and then suddenly there is a huge amperage draw and the core starts blinking a faded red. The neopixel also fades.

Any thoughts based on my design?

It looks ok. Can you isolate the core (remove it) and power through normal USB cable jist to be sure it’s behaving properly? :wink:

prior to adding the converter it worked just fine.
I just plugged it in, wired as is, to USB power and it breathed cyan.

Its when externally powered that seems to be causing a fuss.

Ah great! How about the external supply?

What’s the Amps it can output for 5v?

I also noticed that the 0E pin is left unconnected. The datasheet says pull high for enable but does the board already come wired that way?

Those strips can draw quite a bit of current :smiley:

I forget to mentioned you can leave out the level converter since data is only leaving the core and no data is coming back to it.

So sending the signal at 3.3v is fine. At least that’s what I do with my WS2812b led strips :wink:

The external supply is a 25a bench supply.
When I saw the current spiking I pulled the plug right away.

The description says that OE is pulled up on the breakout.

I am driving 1 neopixel right now (60ma)

It says specifically in the documentation for the neopixel that the data input has to be driven at 5v along with its power.

You might want to restrict the current to 500mA like how a USB port would supply power.

The core itself can do up to 300mA and it’s hard to tell when you pull the plug immediately.

Since they said so in the documentation, feel free to follow it. :smiley:

My personal take is that driving the data pin at 3.3V works just as fine. :wink:

Yes!! - Good advice - some are surprisingly high - check the specs - One strip I had used for a friends’ restaurant that he got online needed 5 amps @ 12V DC!! I couldn’t understand why I was burning up 1 amp supplies until I checked!

I think a conservative gauge is like 20mA per R,G,B which gives 60mA per LED.

A strip of 60 LEDs is like 60 LED x 60mA… 3.6A @ 5V :open_mouth:

:wink:

Sooo…a lesson it never taking anything for granted. The bench supply went belly up. Apparently it is just limping along well enough to supply 3.7, but going up to 5v it couldnt take it anymore. I tried another supply and all breaths cyan like normal.

Thanks for the input everyone. I knew driving just the core and 1 LED couldnt be taxing any normal supply and when I plugged it into the other one it was only drawing 100ma.

1 Like